Version control, Bitbucket, login

Hi All,

I am really struggling with the Windows version of PHPStorm with regard to integrating with Bitbucket. Before going further, I was able to configure everything on the Mac and it works fine across the board. Here is what is happening on the Mac:
- Login works fine using SSH
- It is easy to test from the command line.
- All the features you would expect work fine in PHPStorm, including push, pull etc.
- When you go to settings and test the login in the Bitbucket plugin it tests successfully.

Unfortunately, on the Windows system, I don't even get to first base in terms of using Git (except locally, I can create a local repo) because I can't even login. One of the early configuration steps is to install the Bitbucket plugin. When I go into settings, and put in my credentials and hit test it does nothing except return "Cannot login to Bitbucket" There is no further error message or log that I can find. Both the Mac and PC are running on the same network using the same proxy settings, so i don't think that is the problem. Further, when I use a utility (SmartGit) I can login, clone, push, etc. Go figure.
Any ideas?
Thanks ahead for any help.

Jim

2 comments
Comment actions Permalink

Hello Jim,

BitBucket plugin is supported not by JetBrains, but by Atlassian. Please contact their support.

Meanwhile you may try to set up Git integration without using BitBucket plugin: VCS -> Checkout from version control -> Git -> enter the clone URL manually -> press Clone -> and see if it works.

0
Comment actions Permalink

Hi Kiril and thanks for your reply. Sorry it took so long to respond. I had already tried using git integration without the Bitbucket plugin and still couldn't authenticate. I did, however, figure out the solution and it was very simple. For whateve reason, I had checked use HTTP proxy. When I unchecked it, it all worked fine, just like on my other machine (Mac) and in other software on this machine. Thanks for your help. Maybe this is will be useful to others.

Regards,

Jim

0

Please sign in to leave a comment.