TFS disappears after upgrading to Webstorm 5.0

Hi,

Today, I have done an upgrade for webstorm to 5.0. However, after that, "TFS" is no longer an option under "VCS -> Enable Version Control Integration".

Any suggestion how to bring TFS back is really appreciated.

Thanks

23 comments
Comment actions Permalink

It seems tfs integration is not installed by default. Then i try to download from repository, but it looks like the tf
sintegration plugin is incompatible with webstorm 5.0. can somebody confirm or better fix this ...?

0
Comment actions Permalink

That's intended, we unbundled the plugin based on user base/plugin size.
We'll provide updated downloadable version ASAP.

0
Comment actions Permalink

This needs to be posted on the download page as a warning.

The WebStorm 5 help says:

  • WebStorm comes bundled with TFS plugin. This plugin is turned on by default. If it is not, make sure that the plugin is enabled.

I upgraded thinking this was the case. Now that I can't integrate with TFS like I could with 4, WebStorm is unusable for me. I have to find a way to roll it back.
0
Comment actions Permalink

Hello, i fully agree on that.

I issued the update of my installation today because i hoped that the current version would support integrationg with TFS2012, as this was lacking in v4.3 (youtrack item IDEA-82498).

I's quite frustrating to see TFS integration vanishing completely after fullfilling the update.

A warning on the one hand is greatly appreciated, on the other hand it would be great to offer a separate plugin download to restore at least the capabilities ov v4.3.

Thanks in advance!

0
Comment actions Permalink

Sorry for inconvinience, as a temp solution I'll attach a TFS plugin to http://youtrack.jetbrains.com/issue/WI-13079

0
Comment actions Permalink

Hi Alexey,

many thanks for the quick response!

I have downloaded tthe package and could successfully install the integration plugin.
Connecting  to my old TFS2008 server now works perfectly as expected and known from former versions.

Would be great to see this working later in time for TFS 2012 also.

Many thanks again, cheers!

0
Comment actions Permalink

TFS plugin is now published at JetBrains plugin repository. Please click Settings -> Plugins, then Browse Repositories and look for TFS.

0
Comment actions Permalink

Thanks for this. After downloading the plugin TFS features appear to be working again.

0
Comment actions Permalink

Does it support TFS2012 ?

I keep having this error pop up.

org.apache.axis2.databinding.adbexception unexpected subelement ownerAliases

Thanks

0
Comment actions Permalink

Hi there,

Does it support TFS2012 ?

Unfortunately No -- support for TFS 2012 is added in v6 only (you can try EAP build here: http://eap.jetbrains.com/phpstorm )

0
Comment actions Permalink

But I only used Webstorm 5.0. I just bought it.  Any plan to support TFS2012 ?

0
Comment actions Permalink
Any plan to support TFS2012 ?

Yes -- Support for TFS 2012 will be available in v6.

Because you just bought v5, when v6 will be out (Q2 2013), you will be able to use it as well (since you have subscription for full year of updates/upgrades).

0
Comment actions Permalink

P.S.
My mistake -- I gave you wrong link -- WebStorm EAP is available here: http://eap.jetbrains.com/webstorm

0
Comment actions Permalink

Thanks ! That is what I want.

0
Comment actions Permalink

After I tried several times, uninstall and install, it still doesn't work.

I got this error

org.apache.axis2.databinding.ADBException: Unexpected subelement OwnerAliases.

I checked the version and I was still using the old TFS plugin (121.390)

however, I can't get 124.297 from the repositories.

0
Comment actions Permalink

ok, I finally found the download link for 124.297 version and I think I use a wrong way to install it.

Now it keeps popping up the error message like

Fatal error initializing class com.intellij.openapi.actionsystem.ActionManager
java.util.MissingResourceException: Cant Find bundle for base name org.jetbrains.tfslntegration.core.TFSBundle, locale en_US

It doesn't go away even after I uninstall , reboot and reinstall.

Any idea to fix this ?

0
Comment actions Permalink

Sam, how did you install it?

Can you check that you have resources_en.jar file at c:\Users\USERNAME\.WebIde60\config\plugins\tfsIntegration\lib folder ?

Thanks,
Kirill

0
Comment actions Permalink

The funny thing is I don't even have that folder. I think because I have uninstalled it and reinstalled it.

In my other machine, I can find that folder tho.

I think the problem is why the problem is still existed after I uninstalled it and reinstalled it ?

How can I get a clean slate  ?

BTW, TFS plugin does work now. I installed webstorm on another machine and everything did work like a charm.

0
Comment actions Permalink

What OS are you on?

0
Comment actions Permalink

Finally I found that GOD DAMN FOLDER. I spent a whole day to fix this.

It turns out It is not at normal user folder. It is sitting under a weird folder I have.

I would suggest you guys let ppl can setup that fold path during the installation, don't just pick up from reg or anywhere.

After I uninstall and remove that .WebIDE60 folder and re-install everything work now.

Thanks for keeping working with me.

The good news is everything work on my other machine so I can demo it successfully this morning. And my boss likes it, so we might buy the license for work.

however, TFS only work on 6 and I can't register EAP version. So what will happen after I use EAP after 30 days ?

0
Comment actions Permalink

Sam,

Sorry for that folder, one rarely needs to manually look there indeed.

We'll keep on publishing fresh EAP builds every couple of weeks, so you will always be able to upgrade to the next build before current one expires. And finally you will switch to the release build (currently scheduled to March 2013).

Kirill

0
Comment actions Permalink

Sounds good to me. Thanks for all your hard work. Merry X'mas.

0

Please sign in to leave a comment.