phpStorm doesn't recognize a files' language

I've mistakenly once created a php file using File -> New, then deleted it, and re-created it. Since then, all I see is white syntax. It's no longer a php file for phpStorm. I tried deleting the .idea dir, cleaned caches, searched the config folder.. nothing..

2010-12-09 14 37 59.png



Attachment(s):
2010-12-09 14 37 59.png
5 comments
Comment actions Permalink

please elaborate on "white syntax" part. Screenshot may be helpful.

0
Comment actions Permalink

I added one with the wysiwyg.. weird, added it as attached now too

0
Comment actions Permalink

Settings | File types | Plain text  - > check mapped masks carefully.

1
Comment actions Permalink

Thanks, found that filename there.

0
Comment actions Permalink

Thanks. This helped.
Issue I had was that Phpstorm doesn't recognise a file as a php file.

Heres how I got into the issue and solved it.

- Wanted to add a file abc.php
- By mistake added "abc.php" as a valid file extension to the text files
- So when ever I create any file with abc.php, it was not recognising as a php file.
- Followed
Settings | File types -> Select 'Text files' file type ->  Searched for the "abc.php" from the list of patterns and removed it.

10

Please sign in to leave a comment.