[ Technical Help ] Project set-up initialization, Failed.

Can't create new project which has this error nor, validate my license data which disabled the ok function. Any suggestion?




1.png



Attachment(s):
2.png
9 comments
Comment actions Permalink

Hello,

did you try invalidating caches (File|Invalidate caches...)?
If the problem persists, please, proviude your log  (Help | Reveal log)

0
Comment actions Permalink

this was the first time I use webstorm and this error and disabled control problem surprise me. I even tried completely deleting the whole packages and reinstalling it. btw, does it seem to conflict with other IDE? to be specific, eclipse.. I can't even put my license data with disabled ok function which my only option was a 30free trial and I can't create project with that.

0
Comment actions Permalink

Hello, Elena. Thx for the helping hand. here is the log. further info. I am using 64bit windows with 32bit jdk installed.



Attachment(s):
idea.log.zip
0
Comment actions Permalink

Hello!

no, WebStorm doesn't conflict with any IDE (Eclipse in particular). And having the trial license shouldn't be a problem
Just one idea: seems that WEbStorm has problems saving/loading files to/from your home directory - namely, 'C:/Users/$auce' (as far as I can see from the log). Please, can you try using a different folder for storing its configs/caches? To do this, try specifying a different path in $WS_HOME/bin/idea.proiperties, idea.config.path, idea.system.path, idea.plugins.path and idea.log.path properties

Best regards,
Lena

0
Comment actions Permalink

can you tell me which line there represent the solution?

0
Comment actions Permalink

the corresponding options are already there, in idea.properties file  - you just have to uncomment them and edit the path accordingly:
#---------------------------------------------------------------------
# Uncomment this option if you want to customize path to IDE config folder. Make sure you're using forward slashes
#---------------------------------------------------------------------
# idea.config.path=${user.home}/.WebIde/config

#---------------------------------------------------------------------
# Uncomment this option if you want to customize path to IDE system folder. Make sure you're using forward slashes
#---------------------------------------------------------------------
# idea.system.path=${user.home}/.WebIde/system

#---------------------------------------------------------------------
# Uncomment this option if you want to customize path to user installed plugins folder. Make sure you're using forward slashes
#---------------------------------------------------------------------
# idea.plugins.path=${user.home}/.WebIde/config/plugins

#---------------------------------------------------------------------
# Uncomment this option if you want to customize path to IDE logs folder. Make sure you're using forward slashes.
#---------------------------------------------------------------------
# idea.log.path=${user.home}/.WebIde/system/log

0
Comment actions Permalink

thx, gr8 help.

0
Comment actions Permalink

see also the following issue: http://youtrack.jetbrains.com/issue/IDEA-89688
Your problem seems to be related to having '$' in your path ('C:/Users/$auce)

0

Please sign in to leave a comment.