LiveEdit and Debugger Problem

Hi,

This is a  great tool for development. Wish I didn't need this post :(

My development environment is

=> Windows XP Service Pack 3 Build 2600.

=> Chrome Version 22.0.1229.94 m

=> JetBrains Chrome Extension 0.3.11

I purchased V5.0 of Webstorm for development using Javascript. The debugger worked fine under V5.0 and the latest Google Chrome.

I update to Version 5.0.4 recently. Now the debugger does not work. The browser just opens up a new window. I have checked that the extension is indeed there. In fact if I open the debugger with Version 5.0.0 IDE then the debugger still works. Both IDE's are pointing to the same browser.

I could not get LiveEdit to work on either version. I really want this feature as it one of the reasons I bought the Webstorm.

I assume that there is no need to set up Deployment for the feature to work? I am just testing from a folder on my Hard drive. If I do need to set this up how must I do it for a local folder on my HDD?

I have attached a log of the IDE. Please help!

PS: I am new to Web Development. I come from a firmware background but now now I am writing an embedded web servers for our hardware!



Attachment(s):
idea.log.zip
18 comments

Dunno -- works for me on Windows 7 x64 SP1

Few links first (just in case):

  1. http://blog.jetbrains.com/webide/2012/05/whats-cooking-instant-htmlcss-editing-preview/
  2. http://blog.jetbrains.com/webide/2012/08/liveedit-plugin-features-in-detail/
  3. http://wiki.jetbrains.net/intellij/Debugging_JavaScript_locally_in_Firefox_with_WebStorm_and_PhpStorm

I assume that there is no need to set up Deployment for the feature to work? I am just testing from a folder on my Hard drive. If I do need to set this up how must I do it for a local folder on my HDD?

I'm not sure about this, but accordingly to 1st link it is not necessary (should work with file:// protocol). But in case it is needed -- create "In Place" deployment entry (as files are already where web server will serve them from).

In any case, please check that "Allow access to file URLs" is selected in Chrome for this extension.

I could not get LiveEdit to work on either version.

Make sure that "View | Live Edit" (or Settings | Live Edit | Enable) is selected -- that's required for LiveEdit functionality to work. Possibly you have missed this moment.

I have attached a log of the IDE. Please help!

I'm not a dev, but I do not see anything in the log that tells that IDE made connection to browser extension. In case of successful connection it should be something like this: 2012-11-05 15:12:40,220 [  25690]   INFO - erConnection.BrowserConnection - Browser connected: version 0.3.11, CHROME

P.S.
I have not tried JavaScript debugging in Chrome, only in Firefox so far.

0

For some unknown reason ide web server cannot bind to default port. Can you try to use Windows 7 or Vista instead of Win XP SP3? I understand, you cannot change OS due to WebStorm bug, so, try another solution  — specify (<app dir>/bin/WebStorm.exe.vmoptions) vm properties "
-Drpc.port=63342
-Drpc.onlyAnyHost=true".

0

Hi Vladimir,

Thank you for your quick response!

I went home today and tried Windows 7 64bit. It works fine. Live Edit is so amazing. It is every bit as awesome as the demo. :)

I am not sure why my Work PC is giving problems but it is a Windows XP machine. Perhaps the problem is OS dependant?

I am not sure if it is normal procedure but I had to change the path to Chrome on the XP machine for the WebBrowser Settings since it get installed with the default path used for Windows 7. I wonder if there is any other folder that has the wrong path?

I will let you know tomorrow whether the Port fix you suggested works.

0

I tried the Port Fix suggested for the options file but liveEdit did not work.

I then tried the on another Windows XP and  liveEdit does not work.

I also tried another Windows 7 machine in a virtual box and the feature works.

I can only conclude the problem is Windows XP releated. I hope you guys can fix it. I am not sure if my company has a Windows 7 license readily available for me to upgrade at the moment.

0

Solution: Download https://dl.dropbox.com/u/43511007/webide.jar and copy to <WbStorm app dir>/lib (replace existing file).

0

This did not work for me. Windows 7 Chrome 23.0.1271.97 m.  Extention installed by hand.  Closed and restard chrome and Webstorm.

0

What problem do you have exactly? Did you try latest WebStorm 6 EAP?

0

Same problem as the others on this thread chrome starts but never leaves my home screen console says "Waiting for connection from JetBrains Chrome Extension"  Webstorm 5.04.  Downloaded it from the main page on website.  If I need to get a later version please let me know where to go.  Extention installed by hand per instructions and is listed as an active extention in chrome

0

I'm having a similar problem. I'm evaluating getting a WebStorm license, and I just finished installing the WebStorm 5.0.4 download. The first thing I wanted to try is the LiveEdit feature. Everything seems to work except the "live edit" part :-( That is, the Chrome extension is installed OK, I've enabled the "Allow access to file URLs" options in the extension. If I click in my .html source in WebStorm, the Chrome page highlights the right tag/section of the web page, so that seems to be working correctly. But no matter what I type in WebStorm, the Chrome page does not update "live". The View/Reload in Browser menu option seems to work OK. I'm running Chrome 23.0.1271.97 m under Windows 7.

Any suggestions or things I can check? Since I just downloaded WebStorm, I'm obviously not an expert, so I may have missed some crucial step...

0

Is View -> LiveEdit checked?

Please see http://confluence.jetbrains.net/display/WI/LiveEdit "How do I know what's wrong?"

0

Here's some additional information. I created a .css file to go with the .html file. I added a 'color' attribute, which caused a color chip to appear in the gutter. If I click on it and use the pop-up color dialog to change the color value, I see a real-time update in Chrome as I drag the color widget controls around (very cool, BTW!). But if I manually type in a new color value in the .css file's text editor...no update in Chrome. So some "live edit" stuff works, but typing in the editor doesn't ever seem to generate an update...

0

Yes it is (I should have mentioned that in my original post)...

0

Thanks for feedback. It seems it is known issue. These problems will be fixed in next 6 EAP (next week).

0

OK, thanks for the info. I'll have to give the EAP a try...

0

Just downloaded the latest EAP for WebStorm and LiveEdit seems to be working now...

0

Just a quick follow-up. The EAP did not automatically upgrade my Chrome Extension from 0.3.11 (from WebStorm 5.0.4) to 0.4.8. When I started noticing some other bad LiveEdit behavior, I began to suspect the extension was the culprit. When I manually updated the Chrome Extension to the one in the EAP installation (0.4.8), things began to work much better. Maybe I missed a README note somewhere...

0

Please sign in to leave a comment.