Whitespaces everywhere... how to disable that?

Hello my fellow JS-Developers!

I downloaded the trial of Webstorm recently and I think there's a lot of potential in it.
What keeps me from saying it's great is the fact, that there is no real "line breaking", nor tabs... or at least not with my default configuration.
I try to explain my issue - and I'm sure there's a fancy word to explain everything in one word... but because I don't know it, I'm not quiet sure if one will get my problem...

Anyway, it's like that:
If I start to write a file with a editor like wordpad, I can only click on the characters I tipped: I write some words, I add a line-breaker, I write some other words, aso.
Then I click on the very right side of my document and I'll end up with the cursor on the last character of the line I clicked.

Not so if I write something in Webstorm: I can click anywhere I want and I'll end up at the exact position I clicked... with a bunch of whitespaces between that point and my last character I actually tipped.

I don't like that - and I'm sure that causes my "no-tabs"-problem, because I activated the tabs in the settings...

So my question is: how can I change this behaviour? And out of curiosity: How is this handy to anyone?
I want formated code and not the possibility to write code in the nirvana of my document.

Thank you guys!

3 comments
Comment actions Permalink

Hi Richard,
You should disable checkbox Allow placement of caret after end of line in Settings | Editor.

Regards,
Konstantin

0
Comment actions Permalink

Settings | Editor | Allow placement of caret after end of line

0
Comment actions Permalink

thank you guys!

Still don't understand how this is usefull, or why it's a default behaviour... anyway, now it's all good

0

Please sign in to leave a comment.