Switch behaviour (Ctrl + Tab)

Hy there,

I'm pretty new to WebStorm/PhpStorm and just discovered an (at least to me) unusual behaviour:

In short I'm not able to navigate through all open files/tabs by pressing Ctrl+Tab multiple times. Let me explain this a little more detailed with an example:

  • I'm currently working in Main.js
  • The file i was most recently working in is Messaging.js
  • Press Ctrl+Tab: The switcher screen appears as seen above
  • I'd expect the IDE to switch to the recently used file (Messaging.js) if I release Ctrl+Tab right now (not the next one in the list!)
    That's exactly what happens. So far I'm happy ;)
  • Here's the problem:
    I'd expect the IDE to be able to navigate through all other open files/tabs by pressing the tab-key multiple times as long as the switcher-dialog is open (and the alt-key is still pressed).
  • Unfortunately this is not possible. I'd have to use the mouse or the cursors to navigate inside the switcher-dialog which feels pretty cumbersome to me.

    Is this default behaviour by the IDE or did i discover a bug? Because of the fact that the expected behaviour is pretty much standard in most windows and non-windows applications (Alt+Tab in Windows itself, Ctrl+Tab in Firefox, Chrome, Visual Studio, Eclipse, ...) I'm a little surprised that JetBrains handles this differently.

    I'd really love some feetback on this and am going to fill a feature request if no one responds here.

    1 more things:

    • I already discovered the TabSwitch-Plugin which does not open the  recently used file after pressing Ctrl+Tab once but opens  the next one in the list and additionaly it doesn't show the other tabs (like  Project, Favorites, Database, ...) at all. Therefore this doesn't seem like a real  alternative to me.



    Comment actions Permalink

    Hi there,

    Works fine here in both PhpStorm v5.0.4 and v6 EAP on Windows 7 x64 SP1.

    You press Ctrl+Tab, Keep Ctrl pressed (and not Alt, as you have said) and press Tab again -- it will select another entry in the list -- exactly the same how Alt+Tab works in Windows itself (just Ctrl instead of Alt).

    If that does not work for you (for whatever reason -- maybe try default keymap, in case there are conflicts, don't know..) then you can still use Alt+Left/Right to navigate between opened editor tabs (obviously, it will work when Editor is active/has focus).

    Comment actions Permalink

    Hm, then it seems like a bug. Doesn't work with default keymap neither.
    I'm going to check if this is working on my private notebook or if i can reproduce it somehow and fill a bug report later.

    Thanks for the info

    Comment actions Permalink

    What OS, PhpStorm version and Look and Feel (LAF) are you using? Try another LAF (Settings | Appearance).

    Comment actions Permalink

    OS: Windows 7, 64 Bit, SP1
    PhpStorm 5.0.4

    It doesn't matter which L&F i use. Tried all of them with no difference...

    Comment actions Permalink

    Hmm, somehow, mysteriously the problem disappeared over night... Right now the switcher is working as I would have expected it right from the start.
    The only changes that I'm aware of are the installation of an plugin (AceJump) and chaging 1 or 2 keymaps (can't recall exactly which ones and with which values).

    Unfortunately I don't know if the feature was working today right from the beginning or if it started working after e.g. installing the plugin...

    Thanks for the help nevertheless!

    Comment actions Permalink

    After upgraded my Debian laptop to buster/sid, I have experienced this kind of issue, where I cannot do it at getting keys released. Before upgrading, I could switch files at getting keys released. I use ctrl+tab keys for the switcher function by default. Anyway, I use the  testing version of Debian, and it might be a cause.

    Comment actions Permalink

    Jumeno, do I understand your scenario correctly, releasing "Ctrl" on "Ctrl+Tab" does not select the file and switcher stays here?

    Comment actions Permalink

    I experienced the same issue on Fedora 33. In my case, this was due to the remapping of the Caps Lock key in gnome. It seems that the option `Keyboard & Mouse > Additional layout options > Caps Locks behavior > Caps Lock is also a Ctrl` caused the issue.


    - set the option to `Disabled`

    - set `Ctrl position` to `Caps Lock as Ctrl` in the same menu to get the same effect without impacting Intellij's switcher behavior



    Please sign in to leave a comment.