Cannot Connect To Remove CVS Respository

Suddenly today, I cannot connect to our CVS repo (server06.pridedallas.com) from PHPStorm. My other CVS clients connect just fine and PHPStorm worked fine yesterday. Now, I get

Error: Timeout while trying to connect to host: server06.

I turned on logging for CVS and it shows nothing helpful:


BEGIN AUTH REQUEST
/cvsrepos
keithdavis
@encodedPassword@
END AUTH REQUEST
BEGIN AUTH REQUEST
/cvsrepos
keithdavis
@encodedPassword@
END AUTH REQUEST
BEGIN AUTH REQUEST
/cvsrepos
keithdavis
@encodedPassword@
END AUTH REQUEST

2 comments
Comment actions Permalink

idea.log:

com.intellij.cvsSupport2.errorHandling.CvsException: Timeout while trying to connect to host: server06
at com.intellij.cvsSupport2.cvsoperations.common.LoginPerformer.loginAll(LoginPerformer.java:68)
at com.intellij.cvsSupport2.cvsoperations.common.LoginPerformer.loginAll(LoginPerformer.java:49)
at com.intellij.cvsSupport2.cvsoperations.common.CvsCommandOperation$2.run(CvsCommandOperation.java:279)
at com.intellij.openapi.application.impl.ApplicationImpl$6.run(ApplicationImpl.java:457)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
at com.intellij.openapi.application.impl.ApplicationImpl$1$1.run(ApplicationImpl.java:148)

0
Comment actions Permalink

Well, the problem is something is causing our CVS server to run slow or we are having network issues and PHPStorm times out at 10 seconds. I changed that to 30 and it worked (at about 15 seconds.)

0

Please sign in to leave a comment.