Xdebug falling silent when its phpstorm's turn to play

Server: Centos 6
Server Location: Web Host/Remote/sftp
phpStorm Project setup: Created project from existing files located on my remote web server
Xdebug Installation:

  • Xdebug installed: 2.2.1
  • Server API: Apache 2.0 Handler
  • Windows: no
  • Zend Server: no
  • PHP Version: 5.3.3
  • Zend API nr: 220090626
  • PHP API nr: 20090626
  • Debug Build: no
  • Thread Safe Build: no
  • Configuration File Path: /etc
  • Configuration File: /etc/php.ini
  • Extensions directory: /usr/lib64/php/modules

php.ini settings:
[Zend]

  • zend_extension ="/usr/lib64/php/modules/xdebug.so"
  • xdebug.remote_enable=1
  • ;xdebug.remote_handler=dbgp
  • ;xdebug.remote_mode=req
  • ;xdebug.remote_host=(ip to my server (the one that takes me to my server if I type it into the browser address bar)
  • xdebug.remote_port=9000
  • ;xdebug.remote_log="/var/log/xdebug.log"
  • ;xdebug.remote_autostart=1
  • ;xdebug.idekey = "PHPSTORM"

Note that some lines are commented out. That's just a result of me playing around with the settings for two days. I tried a lot of combinations.
Note also I tried placing my ip as well.

Network Settings:

  • I am using a static IP on my local computer and port 9000 is forwarded and opened.
  • No firewalls are operating right now

Problem:
When I click on the start to listen to debug button on phpstorm and then I navigate to my page and using the bookmark generated from here, I return to phpstorm and... Well nothing. It does nothing. It just sits there. Still listening. Breakpoints are set. Simple echo line. My chrome app Xdebug helper tells me xdebug is enabled on the page.
I looked at every tutorial on the net, I believe, on doing this. What am I doing wrong?

2 comments
Comment actions Permalink

I tried using my computers IP as the xdebug.remote host value. After restarting apache it caused my web server to hang whenever I refresh a page.

0
Comment actions Permalink

Hi there,

This article should have enough info:


xdebug.remote_host -- this should be YOUR IP address were you run PhpStorm. If your server is remote one (not on LAN) then it should be your external IP and port must be opened and routable in router/firewall (you can check your IP via $_SERVER['REMOTE_ADDR'] ).

P.S.
Do not forget restart Apache when making changes in php.ini (it is not re-read on modification).

0

Please sign in to leave a comment.