PhpStorm 5.0.3: JSLint annoyance!

Hello.

As it was already mentioned in the 5.0.3 announcement's comments - JSLint is turned on by default in the latest version of PhpStorm. Probably(!) it's ok. But tell me please!!! Why for God's sake JSLint gets turned on again (after being turned off) with every file of new type being opened and starts to inspect it even if that file is everything but NOT JAVASCRIPT FILE!!! It inspects .css, it inspects .php, it inspects even .twig's!!! And, I repeat, with every new (to JSLint) file type it gets activayed again!!! It just drives me mad for real!

Sorry.

PS: Said above applies to JSHint also...

Regards.
Roman.

3 comments
Comment actions Permalink

Yes -- it is active by default and checks evey file type (the bug is listed, accepted and fixed already). But once turned off (that's the only solution for now) it does not re-activates itself. You will be first who mentions this behaviour (unless PhpStorm does not want to / unable to remember settings changes for some weird reason) -- maybe worth reporting it to the Issue Tracker?.

0
Comment actions Permalink

Correctness: It gets enabled with every new project started.
Maybe it'd be better to make JSLint's settings global and not project-wide?

0
Comment actions Permalink
Correctness: It gets enabled with every new project started.

File | Template Settings ... --- set default values for new projects there

Maybe it'd be better to make JSLint's settings global and not project-wide?

No. It's similar to PHP Code Sniffer: in one project you need one settings (mo strict), on another -- completely different (more relaxed).

0

Please sign in to leave a comment.