12 comments
Comment actions Permalink

How do you use a dmg file to downgrade?  I need to downgrade from WebStorm 5.0.3.  I found its dmg file but Windows doesn't know what to do with it.

0
Comment actions Permalink

Thanks for the quick response.  I'm able to debug under Chrome again.

0
Comment actions Permalink

Thanks for your answers :)

0
Comment actions Permalink

Hi - my question is related, so I figured I would not start a new thread.

My Webstorm license expired on 1-October 2012. As such, I'm eligible for 5.0, but not 5.0.2. I need to re-download 5.0 (for Mac), but cannot find a link anywhere. Modifying the link above to end with 5.0.dmg, or 5.0.1.dmg or 5.0.1.dmg does not seem to work.

Can someone please provide me with the original 5.0 release download link?

Many thanks,

Paul

0
Comment actions Permalink

You (anybody) are eligible for all minor updates (i.e 5.0.x) if your license is valid for 5.0.
This is why older releases are not available for download.

0
Comment actions Permalink

This text is from my license email:

Product Name: WebStorm
Licensed Version: 2.0 and any new product release which is made generally available before 1 October 2012

The software is shipped electronically and is available for download from:
http://www.jetbrains.com/webstorm/download/

Your WebStorm license includes a 1-year upgrade subscription qualifying you for free upgrades to any new versions of WebStorm released by JetBrains during your upgrade subscription period starting on your license issue date and ending on 1 October 2012. To check availability of the new versions of WebStorm, please visit http://www.jetbrains.com.



Yet when I enter my username and license (and I've tried with and without the "license begin/license end" lines, I get "This license is not compatible with current product version"
0
Comment actions Permalink

Upcoming 5.0.4 will work for all eligible for 5.0 - build will be published closer to the weekend.

0
Comment actions Permalink

Should I interpret this as meaning there's a bug in the current version's license/registration code and that 5.0.4 will resolve this?

0
Comment actions Permalink

yes, sorry for inconvinience.

0
Comment actions Permalink

That's ok. Thanks for the swift response - now at least I know what's going on. looking forward to the 5.04 release :-)

0

Please sign in to leave a comment.