10 comments

Hi Mats,

hoping this is easy in WS too?

Yes -- you just need to define one deployment entry (Settings | Deployment) and mark it as Default for this project -- that's where URL will be taken from when opening files in browser.

0

If I view this thread as guest then login, it shows me 'Thread not found', just a heads up.

I'll try this shortly, thanks! What about 'Go to line', could not find that in any menu and in the PhpStorm/WebStorm cheat sheet for Mac it says CMD+L, which does not work.

0

Ok, found the menu option (I was looking for 'Go to line...' and it just said 'Line' :)). Is there no default keybinding for it?

0

Check and change if required: Settings | Keymap | Main Menu | Navigate | Line ...

0

One more thing, to type pipe char |, on a Swedish keyboard on a Mac the key combo is Alt+7 which in WebStorm is mapped to some command. How can I find and unbind which command it is? So far I've been copy pasting pipes, getting tired of that now :)

0
  1. Settings | Keymap
  2. Click on funnel-like icon
  3. Press desired shortcut (the one you are looking for)
  4. Unassign/Reassign it from actions found as required


P.S.
Quite likely it will be assigned to "Main Menu | View | Toolbars | Structure"

0

I still haven't been able to resolve the file:/// issue. Can't find the deploy settings in the preferences. Any guidance on this?

Also your forums are still broken when logging in.

An unexpected error has occurred


  • The specified thread was not found.
0

Settings | Deployment -- it's quite hard to miss.

If you still having hard times finding it -- use quick search (the input box on top left corner of the Settings screen) -- it will filter the settings for you.

Alternative way of finding such settings screen -- use "Help | Find Action...", type "Deployment" (without quotes) and choose "Settings" entry from the result list.

P.S.
Do not forget to mark your deployment entry as Default for this project.

0

There is nothing in my Preferences called Deployment.



Attachment(s):
Screen Shot 2012-10-04 at 10.59.45 AM.png
0

In this case please go to Settings | Plugins -- make sure that "Remote Hosts Access" plugin is enabled (it is bundled plugin and enabled by default).

0

Please sign in to leave a comment.