xDebug not connecting

I am trying to switch to phpstorm but am having trouble getting xdebug to work - it simply hangs wating on a connection, even though the xdebug log 'appears' to have received the connection.

The debugger hangs with the following message: 'Wating for incoming connection with ide key 'phpstorm'."

I am relatively sure everything configured correctly.

PHP Version 5.4.4
PHP Storm Version: 4.0.3

I have attached some screenshots of the settings + an xdebug log extract and my xdebug php configs.

Comment actions Permalink

What version of xdebug?

What are your xdebug config settings in your php.ini
Is the server local or remote?

-- edit --

sorry, see your settings now in the attached docs.

Comment actions Permalink

Hi there,

1. Do you have xdebug proxy actually installed and configured on your server? If not then you do not need to configure it (minor thing, should not be applicable to your case since you are using connect_back option).

2. The xdebug log clearly shows that client (PhpStorm?) communicates and sets breakpoints for /var/www/loc.ubuntu/index.php. The "problem" is that at that time (accordingly to this log) you are executing completely DIFFERENT file: /var/www/loc.ubuntu/phpinfo.php , which is not in your project (accordingly to the screenshots) and therefore even "break on first line" option does nothing, since there is no local copy.

Comment actions Permalink

Hi Andriy, thanks for the reply.

The file /var/www/loc.ubuntu/index.php is on my virtual machine.  I am using the "Use path mappings" settings in the servers configuration.  

Is this incorrect?

Comment actions Permalink

Hi there,

1. The path mappings seems fine for me -- except maybe "host" field -- it should be the value of the actual Host header, not full URL (e.g. just "loc.ubuntu")

2. I do not know what URL you are trying to execute (it is nowhere on screenshots), but the log you have provided says that you were executing completely different file at that time.

In any case I suggest:

Other useful links:


Please sign in to leave a comment.