PHP syntax and code error checks disabled

Until last week PhpStorm was alerting me when I wrote one function name wrong, or in any syntax error.
But now I don't see any warning an errors in right scrollbar.
What should I did wrong, I suppose I closed it accidentally by pressing some keys.

I opened Project Settings/Inspections
and checked all buttons under PHP, but it didn't help.
Is there any more place?

8 comments
Comment actions Permalink

I also changed ""Settings | Editor | Colors & Fonts" to Default.
I also checked for Intentions tab in settings and checked all inside intentions.
Still didn't solve?

0
Comment actions Permalink

That's big problem for me.. I'm thinking to reset all my project or IDE settings to default.
Any suggestions please?

0
Comment actions Permalink

I'm thinking to reset all my project or IDE settings to default.
Any suggestions please?

  1. Back up your current settings ("File | Export Settings..." or manually via file system)
  2. Delete existing settings
  3. Launch PhpStorm -- it will re-create them. Create or open some dummy project (just in case not all settings were re-created)
  4. Exit PhpStorm and compare settings files: your backup and new one -- hopefully it will be easy to spot the issue, as there will be only few files to compare (usually specific area/big feature stores settings in separate file) -- this will help you to "fix it" if it will happen next time (plus you will know what may have caused it)


Later you can restore most of the settings from your backup (faster than configuring all again from scratch)

0
Comment actions Permalink
Any suggestions please?

As for what else could be wrong -- please check if "File | Power Save Mode" is not active.

Also -- please check what options "Inspector guy" has active (you know, that icon of the guy in status bar -- also accessible via "Code | Configure Current File Analysis...") -- but that is for current file only... it should not affect ALL files.

0
Comment actions Permalink

Andriy thank you for help. I solved issue after your message.

0
Comment actions Permalink

Glad to hear.

Could you please share what was wrong .. and possibly the solution you have used (will be useful for other people in similar situation)?

0
Comment actions Permalink

I deleted ".WebIde40" folder and phpStorm created new one. Which solved my issue.
Frankly I didn't compare old and default "WebIde40" folders, because
WebIde40/config has 34
WebIde40/system has 664 files.
I can check it by eye if you can tell me which files should I check for.

0
Comment actions Permalink

Hi there,

You can safely ignore "system" folder -- it has caches/indexes and similar regenerative stuff. I do not think that any file here would cause something like this (because, in this case, you would have some other issue, like completely broken code completion or tons of errors everywhere -- that's why manual deleting of this folder helps in those rare cases when even "File | Invalidate caches..." does not help -- some rare/unknown corruption of some kind, not sure)

You should be interested in "config" folder only, I think "options" sub-folder only as well. I don't know what file to check for sure (since I do not know what was caused it in first place) but try these: editor*.xml, ide.general.xml, options.xml, other.xml ... maybe some other as well (purely based on file names).

0

Please sign in to leave a comment.