Cannot use the dollar sign '$' within PHPstorm 3.0

Hello,

I can't use the '$' dollar sign symbol in any php file or html file within PHPStorm 3.0 , it works completely fine in phpstorm 2.1.5 though.

See link to video for visual:

http://www.screencast-o-matic.com/watch/cXlo0BvMC

Anybody else have this issue and know of a fix?

Is there any specific information that is needed to help troubleshoot?

6 comments

Your OS?
Mac Os 10.7, everything okay.
Maybe, problem with keyboard? Or maybe with os language and keyboard settings

0

I use Windows 7 64-bit

It may be something new conflciting with my keyboard within PHPStorm 3.0 but I'm not sure what it could be.

PHPStorm 2.1.5 works fine for me

Thanks

0

Hi Ryan,

1) Maybe you or some plugin mapped that key for some other action/functionality. To check:

  • File | Settings | Keymap
  • Click on funnel-like icon (after search field, before bin icon)
  • Press that key combo there (Shift+4, which should print $ sign in editor)

If no results found ... then it's something else.

Alternatively (or even in addition) try changing to another keymap (just to see if it will work there)

2) Try disabling any 3rd party plugins (in case they have anything to do with that)

3) If still nothing --- backup and delete all settings ( C:\Users\<USERNAME>\.WebIde10\config )

0

Disabling 3rd party plugins one by one was what fixed it.

The culprit is the 'Extended Code Sense' plugin , version 1.3

Thanks

0

Thanks! That was bugging the hell out of me, and I clean forgot I'd installed the plugin a couple days ago.

0

Please sign in to leave a comment.