github "repository test has failed"

Im not able to checkout anything from Github.

I can put in the "Git Repository URL" and have the "accept key YES / NOP" dialog open.  click yes, it all seams to have worked, but on clicking TEST i get a red message that says:
"repository test has failed"

Not sure what to do next, i tried both the https// github url and the ssh github url. both show the same error.

Searching the issue tracker i found this:
http://youtrack.jetbrains.com/issue/IDEA-86712

Which the asker says "Turns out my id_rsa key was invalid."  but no steps on how to fix this issue.

any ideas?

- - edit - -
I CAN still pull from a repository that I added earlier on and when I do click the TEST button on that phpstorm instance, it too gives me the "repository test has failed" message.

4 comments
Comment actions Permalink

Just found the answer.

The answer is "Dont Test, just do it."

Test fails. but before you click the test button the CLONE button is active.  just click it, it works.  click test first and when it fails the CLONE button will become inactive, so dont do it.

0
Comment actions Permalink

I have the same Issue, proposed solution doesn't work

0
Comment actions Permalink

Does it work when you try to pull from Terminal?

0

Please sign in to leave a comment.