French characters not liked in phpStorm

Hello,

I have a lang file with chars like é è à into it. Opened into notepad++, it's all fine, but in phpStorm, I see <?> chars.

What should I do ?

edit: Forgot to say, I'm using the latest 4.0 as a 30 days trial test.



Attachment(s):
2012-06-07_04-58-13PM.jpg
2 comments
Comment actions Permalink

Hi Sebastien,

Most likely you need to set correct text encoding for that file.

  • Either in Settings | File Encodings
  • or the same via status bar


If autodetected encoding is UTF-8 and PhpStorm does not allow you to change it -- in "Settings | File Encodings" uncheck "Autodetect UTF-encoded files" and restart PhpStorm.

0
Comment actions Permalink

cool, set it to windows-1252 and it work well, thanks! :)

0

Please sign in to leave a comment.