How do I prevent PhpStorm from debugging PHP CLI?

I use a commercial application that uses the PHP CLI to run a script when exporting data. It isn't part of any project created in PhpStorm.

Everytime I run the export function in this package, PhpStorm fires up and takes me into debugging the script. How do I stop this from happening and control which scripts are to be debugged and which ones aren't?

4 comments
Comment actions Permalink

Hi Aidan,

I guess you have
1) "xdebug.remote_autostart = 1"
2) and PhpStorm is set to listen for incomming debug connections (Run | Start Listen PHP Debug Connections) or you are in debug mode already

In any case, try unchecking Settings | PHP | Debug | Force break at first line when script is outside the project (as well as another "Force ..." option on the same settings page)

Another solution would be to use different php.ini (where you do not have any debug module loaded) for your dvelopment and that exporting data script (or even separate php installations, if it's easier)

0
Comment actions Permalink

Thanks for your help - I tried that and it didn't work.

After much headscratching I figured it out. *.php had some how got associated with phpstorm which is fine if all you want to do is work on scripts that run a server!!

0
Comment actions Permalink

Aidan,

Do you still have any issues with debugging?

Thank you for feedback!

0
Comment actions Permalink

I think I'm OK now - thanks for the help

Aidan

0

Please sign in to leave a comment.