Connectivity issue between PhpStorm and xdebug

I'm evaluating PhpStorm v3.0.2

I have failed to start a remote Zend debug session, so i'm trying my luck with xdebug.

After struggling for couple of hours, I dived into the logs to the communication between PhpStorm and xdebug:
Here's the log for xdebug:

Log opened at 2012-02-29 18:30:26 -> <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" fileuri="file:///media/app_eagle_2011_11_22/admin_console/web/index.php" language="PHP" protocol_version="1.0" appid="4025" idekey="PHPSTORM"><engine version="2.1.3"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[]]></url><copyright><![CDATA[Copyright (c) 2002-2012 by Derick Rethans]]></copyright></init> <- feature_set -i 0 -n show_hidden -v 1 -> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="feature_set" transaction_id="0" feature="show_hidden" success="1"></response> <- feature_set -i 1 -n max_depth -v 1 -> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="feature_set" transaction_id="1" feature="max_depth" success="1"></response> <- feature_set -i 2 -n max_children -v 100 -> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="feature_set" transaction_id="2" feature="max_children" success="1"></response> <- step_into -i 3 -> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="step_into" transaction_id="3" status="stopping" reason="ok"></response> <- eval -i 4 -- aXNzZXQoJF9DT09LSUVbJ1BIUFNUT1JNX1hERUJVR19CUkVBSyddKQ== -> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="eval" transaction_id="4"><error code="5"><message><![CDATA[command is not available]]></message></error></response> Log closed at 2012-02-29 18:30:28

and the log PhpStorm log:

2012-02-29 20:30:31,952 [  27951]  DEBUG - .connection.PhpDebugConnection - 775598#<-InitNotificationcom.jetbrains.php.debug.xdebug.dbgp.messages.InitNotification@1e28c99 2012-02-29 20:30:31,964 [  27963]  DEBUG - .connection.PhpDebugConnection - 775598#----connection started 2012-02-29 20:30:31,965 [  27964]  DEBUG - .connection.PhpDebugConnection - 775598#->FeatureSetRequestcom.jetbrains.php.debug.xdebug.dbgp.messages.FeatureSetRequest@469b16 2012-02-29 20:30:31,969 [  27968]  DEBUG - bug.dbgp.messages.DbgpResponse - <?xml version="1.0" encoding="UTF-8"?> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="feature_set" transaction_id="0" feature="show_hidden" success="1" /> 2012-02-29 20:30:31,969 [  27968]  DEBUG - .connection.PhpDebugConnection - 775598#<-SetResponsecom.jetbrains.php.debug.xdebug.dbgp.messages.SetResponse@1f35ded 2012-02-29 20:30:31,970 [  27969]  DEBUG - .connection.PhpDebugConnection - 775598#->FeatureSetRequestcom.jetbrains.php.debug.xdebug.dbgp.messages.FeatureSetRequest@b49cf1 2012-02-29 20:30:31,971 [  27970]  DEBUG - bug.dbgp.messages.DbgpResponse - <?xml version="1.0" encoding="UTF-8"?> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="feature_set" transaction_id="1" feature="max_depth" success="1" /> 2012-02-29 20:30:31,971 [  27970]  DEBUG - .connection.PhpDebugConnection - 775598#<-SetResponsecom.jetbrains.php.debug.xdebug.dbgp.messages.SetResponse@1abc0bd 2012-02-29 20:30:31,971 [  27970]  DEBUG - .connection.PhpDebugConnection - 775598#->FeatureSetRequestcom.jetbrains.php.debug.xdebug.dbgp.messages.FeatureSetRequest@fabc3a 2012-02-29 20:30:31,973 [  27972]  DEBUG - bug.dbgp.messages.DbgpResponse - <?xml version="1.0" encoding="UTF-8"?> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="feature_set" transaction_id="2" feature="max_children" success="1" /> 2012-02-29 20:30:31,973 [  27972]  DEBUG - .connection.PhpDebugConnection - 775598#<-SetResponsecom.jetbrains.php.debug.xdebug.dbgp.messages.SetResponse@15b92b3 2012-02-29 20:30:31,974 [  27973]  DEBUG - .connection.PhpDebugConnection - 775598#->StepIntoRequestcom.jetbrains.php.debug.xdebug.dbgp.messages.StepIntoRequest@5c27f0 2012-02-29 20:30:32,752 [  28751]  DEBUG - bug.dbgp.messages.DbgpResponse - <?xml version="1.0" encoding="UTF-8"?> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="step_into" transaction_id="3" status="stopping" reason="ok" /> 2012-02-29 20:30:32,753 [  28752]  DEBUG - .connection.PhpDebugConnection - 775598#<-StatusResponsecom.jetbrains.php.debug.xdebug.dbgp.messages.StatusResponse@7fd24a 2012-02-29 20:30:33,105 [  29104]  DEBUG - .connection.PhpDebugConnection - 775598#->EvalRequestcom.jetbrains.php.debug.xdebug.dbgp.messages.EvalRequest@1762fef 2012-02-29 20:30:33,128 [  29127]  DEBUG - bug.dbgp.messages.DbgpResponse - <?xml version="1.0" encoding="UTF-8"?> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="eval" transaction_id="4">   <error code="5">     <message><![CDATA[command is not available]]></message>   </error> </response> 2012-02-29 20:30:33,128 [  29127]  DEBUG - .connection.PhpDebugConnection - 775598#<-ErrorResponsecom.jetbrains.php.debug.xdebug.dbgp.messages.ErrorResponse@f5d656 2012-02-29 20:30:33,136 [  29135]  DEBUG - .connection.PhpDebugConnection - 775598#---Start detaching 2012-02-29 20:30:33,136 [  29135]  DEBUG - .connection.PhpDebugConnection - 775598#---Start initializing 2012-02-29 20:30:33,138 [  29137]  DEBUG - .connection.PhpDebugConnection - 775598#---input stream is finished 2012-02-29 20:30:33,138 [  29137]  DEBUG - .connection.PhpDebugConnection - 775598#---stop reading 2012-02-29 20:30:33,145 [  29144]  DEBUG - .connection.PhpDebugConnection - 775598#->RunRequestcom.jetbrains.php.debug.xdebug.dbgp.messages.RunRequest@145af1f 2012-02-29 20:30:33,146 [  29145]  DEBUG - .connection.PhpDebugConnection - 775598#---stop writing 2012-02-29 20:30:33,146 [  29145]  DEBUG - .connection.PhpDebugConnection - 775598#----connection stopped 2012-02-29 20:30:33,146 [  29145]  DEBUG - .connection.PhpDebugConnection - 775598#---Stop detaching

I guess the issue is related to the "command is not available" response message.

PhpStorm is running on windows
Php & xdebug are running on a local ubuntu virtual machine
xdebug version 2.1.3
I'm using symlinks

Any help to further troubleshoot my issue is appreciated.

Comment actions Permalink

Hello Roman,

Please check your xdebug configuration - you need to set 'xdebug.remote_mode'( option to 'req' (it seems that now it is 'jit').

Thank you for feedback!

Comment actions Permalink

Thanks Nikolay,
xdebug.remote_mode is set to it's default value of "req"

The only xdebug options I changed are the following:


I was able to run zend debugger. i think the windows firewall was blocking connections to PhpStorm's process from my virtual machine.
But I would love to see xdebug working as well.. this time I feel really close to get it up and running than any other time in the past :)

Comment actions Permalink


Please attach your phpinfo() output (ensure that it corresponds to interpreter configuration installed on web server, so it is better to get phpingo() output from web page).

Thank you for feedback!

Comment actions Permalink
PHP Logo

PHP Version 5.3.2-1ubuntu4.11

System Linux ubuntu 2.6.32-37-generic #81-Ubuntu SMP Fri Dec 2 20:35:14 UTC 2011 i686
Build Date Dec 13 2011 18:33:00
Server API Apache 2.0 Handler
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc/php5/apache2
Loaded Configuration File /etc/php5/apache2/php.ini
Scan this dir for additional .ini files /etc/php5/apache2/conf.d
Additional .ini files parsed /etc/php5/apache2/conf.d/curl.ini, /etc/php5/apache2/conf.d/gd.ini, /etc/php5/apache2/conf.d/imap.ini, /etc/php5/apache2/conf.d/memcache.ini, /etc/php5/apache2/conf.d/mysql.ini, /etc/php5/apache2/conf.d/mysqli.ini, /etc/php5/apache2/conf.d/pdo.ini, /etc/php5/apache2/conf.d/pdo_mysql.ini, /etc/php5/apache2/conf.d/ssh2.ini, /etc/php5/apache2/conf.d/xdebug.ini, /etc/php5/apache2/conf.d/xsl.ini, /etc/php5/apache2/conf.d/zend.ini
PHP API 20090626
PHP Extension 20090626
Zend Extension 220090626
Zend Extension Build API220090626,NTS
PHP Extension Build API20090626,NTS
Debug Build no
Thread Safety disabled
Zend Memory Manager enabled
Zend Multibyte Support disabled
IPv6 Support enabled
Registered PHP Streams https, ftps,  compress.zlib, compress.bzip2, php, file, glob, data, http, ftp, phar,  zip,, ssh2.exec, ssh2.tunnel, ssh2.scp, ssh2.sftp
Registered Stream Socket Transports tcp, udp, unix, udg, ssl, sslv3, sslv2, tls
Registered Stream Filters zlib.*, bzip2.*, convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk

Suhosin logo This server is protected with the Suhosin Patch
Copyright (c) 2006-2007 Hardened-PHP Project Copyright (c) 2007-2009 SektionEins GmbH

Zend logo This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with Xdebug v2.1.3, Copyright (c) 2002-2012, by Derick Rethans
    with Zend Debugger v5.3, Copyright (c) 1999-2010, by Zend Technologies

PHP Credits



Apache Version Apache/2.2.14 (Ubuntu)
Apache API Version 20051115
Server Administrator [no address given]
Hostname:Port kaltura.ubuntu:0
User/Group www-data(33)/33
Max Requests Per Child: 0 - Keep Alive: on - Max Per Connection: 100
Timeouts Connection: 300 - Keep-Alive: 15
Virtual Server Yes
Server Root /etc/apache2
Loaded Modules core mod_log_config  mod_logio prefork http_core mod_so mod_alias mod_auth_basic  mod_authn_file mod_authz_default mod_authz_groupfile mod_authz_host  mod_authz_user mod_autoindex mod_cgi mod_deflate mod_dir mod_env  mod_expires mod_file_cache mod_filter mod_headers mod_mime  mod_negotiation mod_php5 mod_proxy mod_reqtimeout mod_rewrite  mod_setenvif mod_status

Directive Local Value Master Value
engine 1 1
last_modified 0 0
xbithack 0 0

Apache Environment

Variable Value
SCRIPT_URL /api_v3/phpinfo.php
SCRIPT_URI http://kaltura.ubuntu/api_v3/phpinfo.php
HTTP_HOST kaltura.ubuntu
HTTP_USER_AGENT Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20120216 Firefox/3.6.27
HTTP_ACCEPT text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
HTTP_ACCEPT_CHARSET ISO-8859-1,utf-8;q=0.7,*;q=0.7
HTTP_COOKIE __utma=120182162.540143125.1297345532.1330623565.1330731780.330;   __utmz=120182162.1297345532.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none);  uv=uv_001c2e2aa3b03edb32ef7a94f8480d64; __utmc=120182162;  ZDEDebuggerPresent=php,phtml,php3; PHPSESSID=r3pca4utdrgbbsa60li83o4lm2;  __utmb=120182162.2.10.1330731780
PATH /usr/local/bin:/usr/bin:/bin
SERVER_SIGNATURE <address>Apache/2.2.14 (Ubuntu) Server at kaltura.ubuntu Port 80</address>
SERVER_SOFTWARE Apache/2.2.14 (Ubuntu)
SERVER_NAME kaltura.ubuntu
DOCUMENT_ROOT /var/www/kaltura/app/alpha/web
SERVER_ADMIN [no address given]
SCRIPT_FILENAME /var/www/kaltura/app/api_v3/web/phpinfo.php
REQUEST_URI /api_v3/phpinfo.php
SCRIPT_NAME /api_v3/phpinfo.php

HTTP Headers Information

HTTP Request Headers
HTTP Request GET /api_v3/phpinfo.php HTTP/1.1
Host kaltura.ubuntu
User-Agent Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20120216 Firefox/3.6.27
Accept text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language en-us,en;q=0.5
Accept-Encoding gzip,deflate
Accept-Charset ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive 115
Connection keep-alive
Cookie __utma=120182162.540143125.1297345532.1330623565.1330731780.330;   __utmz=120182162.1297345532.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none);  uv=uv_001c2e2aa3b03edb32ef7a94f8480d64; __utmc=120182162;  ZDEDebuggerPresent=php,phtml,php3; PHPSESSID=r3pca4utdrgbbsa60li83o4lm2;  __utmb=120182162.2.10.1330731780
HTTP Response Headers
X-Powered-By PHP/5.3.2-1ubuntu4.11
Set-Cookie ZDEDebuggerPresent=php,phtml,php3; path=/
Vary Accept-Encoding
Content-Encoding gzip


BCMath support enabled

Directive Local Value Master Value
bcmath.scale 0 0


BZip2 Support Enabled
Stream Wrapper support compress.bz2://
Stream Filter support bzip2.decompress, bzip2.compress
BZip2 Version 1.0.5, 10-Dec-2007


Calendar support enabled


PHP Version 5.3.2-1ubuntu4.11

Directive Local Value Master Value
allow_call_time_pass_reference Off Off
allow_url_fopen On On
allow_url_include Off Off
always_populate_raw_post_data Off Off
arg_separator.input & &
arg_separator.output & &
asp_tags Off Off
auto_append_file no value no value
auto_globals_jit On On
auto_prepend_file no value no value
browscap no value no value
default_charset no value no value
default_mimetype text/html text/html
define_syslog_variables Off Off
disable_classes no value no value
disable_functions no value no value
display_errors On On
display_startup_errors On On
doc_root no value no value
docref_ext no value no value
docref_root no value no value
enable_dl Off Off
error_append_string no value no value
error_log no value no value
error_prepend_string no value no value
error_reporting 22527 22527
exit_on_timeout Off Off
expose_php On On
extension_dir /usr/lib/php5/20090626+lfs /usr/lib/php5/20090626+lfs
file_uploads On On #FFFFFF #FFFFFF
highlight.comment #FF8000 #FF8000
highlight.default #0000BB #0000BB
highlight.html #000000 #000000
highlight.keyword #007700 #007700
highlight.string #DD0000 #DD0000
html_errors Off Off
ignore_repeated_errors Off Off
ignore_repeated_source Off Off
ignore_user_abort Off Off
implicit_flush Off Off
include_path .:/usr/share/php:/usr/share/pear .:/usr/share/php:/usr/share/pear
log_errors On On
log_errors_max_len 1024 1024
magic_quotes_gpc Off Off
magic_quotes_runtime Off Off
magic_quotes_sybase Off Off
mail.add_x_header On On
mail.force_extra_parameters no value no value
mail.log no value no value
max_execution_time 60 30
max_file_uploads 20 20
max_input_nesting_level 64 64
max_input_time 60 60
memory_limit 128M 128M
open_basedir no value no value
output_buffering 4096 4096
output_handler no value no value
post_max_size 2024M 200M
precision 14 14
realpath_cache_size 16K 16K
realpath_cache_ttl 120 120
register_argc_argv Off Off
register_globals Off Off
register_long_arrays Off Off
report_memleaks On On
report_zend_debug On On
request_order EGPCS CGP
safe_mode Off Off
safe_mode_exec_dir no value no value
safe_mode_gid Off Off
safe_mode_include_dir no value no value
sendmail_from no value no value
sendmail_path /usr/sbin/sendmail -t -i /usr/sbin/sendmail -t -i
serialize_precision 100 100
short_open_tag On On
SMTP localhost localhost
smtp_port 25 25
sql.safe_mode Off Off
track_errors Off Off
unserialize_callback_func no value no value
upload_max_filesize 2000M 200M
upload_tmp_dir no value no value
user_dir no value no value
user_ini.cache_ttl 300 300
user_ini.filename .user.ini .user.ini
variables_order EGPCS GPCS
xmlrpc_error_number 0 0
xmlrpc_errors Off Off
y2k_compliance On On
zend.enable_gc On On


ctype functions enabled


cURL support enabled
cURL Information 7.19.7
Age 3
AsynchDNS No
Debug No
GSS-Negotiate Yes
IPv6 Yes
Largefile Yes
krb4 No
libz Yes
CharConv No
Protocols tftp, ftp, telnet, dict, ldap, ldaps, http, file, https, ftps
Host i486-pc-linux-gnu
SSL Version OpenSSL/0.9.8k
ZLib Version


date/time support enabled
"Olson" Timezone Database Version 0.system
Timezone Database internal
Default timezone Asia/Jerusalem

Directive Local Value Master Value
date.default_latitude 31.7667 31.7667
date.default_longitude 35.2333 35.2333
date.sunrise_zenith 90.583333 90.583333
date.sunset_zenith 90.583333 90.583333
date.timezone no value no value


DBA support enabled
Supported handlers cdb cdb_make db4 inifile flatfile

Directive Local Value Master Value
dba.default_handler flatfile flatfile


DOM/XML enabled
DOM/XML API Version 20031129
libxml Version 2.7.6
HTML Support enabled
XPath Support enabled
XPointer Support enabled
Schema Support enabled
RelaxNG Support enabled


Regex Library Bundled library enabled


EXIF Support enabled
EXIF Version 1.4 $Id: exif.c 293036 2010-01-03 09:23:27Z sebastian $
Supported EXIF Version 0220
Supported filetypes JPEG,TIFF

Directive Local Value Master Value
exif.decode_jis_intel JIS JIS
exif.decode_jis_motorola JIS JIS
exif.decode_unicode_intel UCS-2LE UCS-2LE
exif.decode_unicode_motorola UCS-2BE UCS-2BE
exif.encode_jis no value no value
exif.encode_unicode ISO-8859-15 ISO-8859-15


fileinfo support enabled
version 1.0.5-dev


Input Validation and Filtering enabled
Revision $Revision: 294106 $

Directive Local Value Master Value
filter.default unsafe_raw unsafe_raw
filter.default_flags no value no value


FTP support enabled


GD Support enabled
GD Version 2.0
FreeType Support enabled
FreeType Linkage with freetype
FreeType Version 2.3.11
T1Lib Support enabled
GIF Read Support enabled
GIF Create Support enabled
JPEG Support enabled
libJPEG Version 6b
PNG Support enabled
libPNG Version 1.2.42
WBMP Support enabled

Directive Local Value Master Value
gd.jpeg_ignore_warning 0 0


GetText Support enabled


hash support enabled
Hashing Engines md2 md4 md5 sha1  sha224 sha256 sha384 sha512 ripemd128 ripemd160 ripemd256 ripemd320  whirlpool tiger128,3 tiger160,3 tiger192,3 tiger128,4 tiger160,4  tiger192,4 snefru snefru256 gost adler32 crc32 crc32b salsa10 salsa20  haval128,3 haval160,3 haval192,3 haval224,3 haval256,3 haval128,4  haval160,4 haval192,4 haval224,4 haval256,4 haval128,5 haval160,5  haval192,5 haval224,5 haval256,5


iconv support enabled
iconv implementation glibc
iconv library version 2.11.1

Directive Local Value Master Value
iconv.input_encoding ISO-8859-1 ISO-8859-1
iconv.internal_encoding ISO-8859-1 ISO-8859-1
iconv.output_encoding ISO-8859-1 ISO-8859-1


IMAP c-Client Version 2007e
SSL Support enabled
Kerberos Support enabled


json support enabled
json version 1.2.1


libXML support active
libXML Compiled Version 2.7.6
libXML Loaded Version 20706
libXML streams enabled


Multibyte Support enabled
Multibyte string engine libmbfl
HTTP input encoding translation disabled

mbstring extension makes use of "streamable  kanji code filter and converter", which is distributed under the GNU  Lesser General Public License version 2.1.

Multibyte (japanese) regex support enabled
Multibyte regex (oniguruma) backtrack check On
Multibyte regex (oniguruma) version 4.7.1

Directive Local Value Master Value
mbstring.detect_order no value no value
mbstring.encoding_translation Off Off
mbstring.func_overload 0 0
mbstring.http_input pass pass
mbstring.http_output pass pass
mbstring.http_output_conv_mimetypes ^(text/|application/xhtml\+xml) ^(text/|application/xhtml\+xml)
mbstring.internal_encoding no value no value
mbstring.language neutral neutral
mbstring.strict_detection Off Off
mbstring.substitute_character no value no value


memcache support enabled
Version 3.0.4
Revision $Revision: $

Directive Local Value Master Value
memcache.allow_failover 1 1
memcache.chunk_size 32768 32768
memcache.compress_threshold 20000 20000
memcache.default_port 11211 11211
memcache.hash_function crc32 crc32
memcache.hash_strategy consistent consistent
memcache.lock_timeout 15 15
memcache.max_failover_attempts 20 20
memcache.protocol ascii ascii
memcache.redundancy 1 1
memcache.session_redundancy 2 2


MHASH support Enabled
MHASH API Version Emulated Support


MySQL Support enabled
Active Persistent Links 0
Active Links 0
Client API version 5.1.41
MYSQL_SOCKET /var/run/mysqld/mysqld.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib -lmysqlclient_r

Directive Local Value Master Value
mysql.allow_local_infile On On
mysql.allow_persistent On On
mysql.connect_timeout 60 60
mysql.default_host no value no value
mysql.default_password no value no value
mysql.default_port no value no value
mysql.default_socket /var/run/mysqld/mysqld.sock /var/run/mysqld/mysqld.sock
mysql.default_user no value no value
mysql.max_links Unlimited Unlimited
mysql.max_persistent Unlimited Unlimited
mysql.trace_mode Off Off


MysqlI Support enabled
Client API library version 5.1.41
Active Persistent Links 0
Inactive Persistent Links 0
Active Links 0
Client API header version 5.1.41
MYSQLI_SOCKET /var/run/mysqld/mysqld.sock

Directive Local Value Master Value
mysqli.allow_local_infile On On
mysqli.allow_persistent On On
mysqli.default_host no value no value
mysqli.default_port 3306 3306
mysqli.default_pw no value no value
mysqli.default_socket no value no value
mysqli.default_user no value no value
mysqli.max_links Unlimited Unlimited
mysqli.max_persistent Unlimited Unlimited
mysqli.reconnect Off Off


OpenSSL support enabled
OpenSSL Library Version OpenSSL 0.9.8k 25 Mar 2009
OpenSSL Header Version OpenSSL 0.9.8k 25 Mar 2009


PCRE (Perl Compatible Regular Expressions) Support enabled
PCRE Library Version 7.8 2008-09-05

Directive Local Value Master Value
pcre.backtrack_limit 100000 100000
pcre.recursion_limit 100000 100000


PDO support enabled
PDO drivers mysql


PDO Driver for MySQL enabled
Client API version 5.1.41


Phar: PHP Archive support enabled
Phar EXT version 2.0.1
Phar API version 1.1.1
SVN revision $Revision: 290435 $
Phar-based phar archives enabled
Tar-based phar archives enabled
ZIP-based phar archives enabled
gzip compression enabled
bzip2 compression enabled
OpenSSL support enabled

Phar based on pear/PHP_Archive, original concept by Davey Shafik.
Phar fully realized by Gregory Beaver and Marcus Boerger.
Portions of tar implementation Copyright (c) 2003-2009 Tim Kientzle.

Directive Local Value Master Value
phar.cache_list no value no value
phar.readonly On On
phar.require_hash On On


Revision $Revision: 293036 $


Reflection enabled
Version $Revision: 293036 $


Session Support enabled
Registered save handlers files user memcache
Registered serializer handlers php php_binary wddx

Directive Local Value Master Value
session.auto_start Off Off
session.bug_compat_42 Off Off
session.bug_compat_warn Off Off
session.cache_expire 180 180
session.cache_limiter nocache nocache
session.cookie_domain no value no value
session.cookie_httponly Off Off
session.cookie_lifetime 0 0
session.cookie_path / /
session.cookie_secure Off Off
session.entropy_file no value no value
session.entropy_length 0 0
session.gc_divisor 1000 1000
session.gc_maxlifetime 1440 1440
session.gc_probability 1 1
session.hash_bits_per_character 5 5
session.hash_function 0 0 PHPSESSID PHPSESSID
session.referer_check no value no value
session.save_handler files files
session.save_path /var/lib/php5 /var/lib/php5
session.serialize_handler php php
session.use_cookies On On
session.use_only_cookies On On
session.use_trans_sid 0 0


shmop support enabled


Simplexml support enabled
Revision $Revision: 293036 $
Schema support enabled


Soap Client enabled
Soap Server enabled

Directive Local Value Master Value
soap.wsdl_cache 1 1
soap.wsdl_cache_dir /tmp /tmp
soap.wsdl_cache_enabled 1 1
soap.wsdl_cache_limit 5 5
soap.wsdl_cache_ttl 86400 86400


Sockets Support enabled


SPL support enabled
Interfaces Countable, OuterIterator, RecursiveIterator, SeekableIterator, SplObserver, SplSubject
Classes AppendIterator,  ArrayIterator, ArrayObject, BadFunctionCallException,  BadMethodCallException, CachingIterator, DirectoryIterator,  DomainException, EmptyIterator, FilesystemIterator, FilterIterator,  GlobIterator, InfiniteIterator, InvalidArgumentException,  IteratorIterator, LengthException, LimitIterator, LogicException,  MultipleIterator, NoRewindIterator, OutOfBoundsException,  OutOfRangeException, OverflowException, ParentIterator, RangeException,  RecursiveArrayIterator, RecursiveCachingIterator,  RecursiveDirectoryIterator, RecursiveFilterIterator,  RecursiveIteratorIterator, RecursiveRegexIterator,  RecursiveTreeIterator, RegexIterator, RuntimeException,  SplDoublyLinkedList, SplFileInfo, SplFileObject, SplFixedArray, SplHeap,  SplMinHeap, SplMaxHeap, SplObjectStorage, SplPriorityQueue, SplQueue,  SplStack, SplTempFileObject, UnderflowException,  UnexpectedValueException


SSH2 support enabled
extension version 0.11.0-dev
libssh2 version 1.2.2
banner SSH-2.0-libssh2_1.2.2
remote forwarding enabled
hostbased auth enabled
polling support enabled
publickey subsystem enabled


Dynamic Library Support enabled
Path to sendmail /usr/sbin/sendmail -t -i

Directive Local Value Master Value 1 1
assert.bail 0 0
assert.callback no value no value
assert.quiet_eval 0 0
assert.warning 1 1
auto_detect_line_endings 0 0
default_socket_timeout 60 60
safe_mode_allowed_env_vars PHP_ PHP_
safe_mode_protected_env_vars LD_LIBRARY_PATH LD_LIBRARY_PATH
url_rewriter.tags a=href,area=href,frame=src,input=src,form=fakeentry a=href,area=href,frame=src,input=src,form=fakeentry
user_agent no value no value


sysvmsg support enabled
Revision $Revision: 293036 $


Tokenizer Support enabled


WDDX Support enabled
WDDX Session Serializer enabled


xdebug support enabled
Version 2.1.3

Supported protocols Revision
DBGp - Common DeBuGger Protocol $Revision: 1.145 $

Directive Local Value Master Value
xdebug.auto_trace Off Off
xdebug.collect_assignments Off Off
xdebug.collect_includes On On
xdebug.collect_params 0 0
xdebug.collect_return Off Off
xdebug.collect_vars Off Off
xdebug.default_enable On On
xdebug.dump.COOKIE no value no value
xdebug.dump.ENV no value no value
xdebug.dump.FILES no value no value
xdebug.dump.GET no value no value
xdebug.dump.POST no value no value
xdebug.dump.REQUEST no value no value
xdebug.dump.SERVER no value no value
xdebug.dump.SESSION no value no value
xdebug.dump_globals On On
xdebug.dump_once On On
xdebug.dump_undefined Off Off
xdebug.extended_info On On
xdebug.file_link_format no value no value
xdebug.idekey no value no value
xdebug.max_nesting_level 100 100
xdebug.overload_var_dump On On
xdebug.profiler_aggregate Off Off
xdebug.profiler_append Off Off
xdebug.profiler_enable Off Off
xdebug.profiler_enable_trigger Off Off
xdebug.profiler_output_dir /tmp /tmp
xdebug.profiler_output_name cachegrind.out.%p cachegrind.out.%p
xdebug.remote_autostart Off Off
xdebug.remote_connect_back Off Off
xdebug.remote_cookie_expire_time 3600 3600
xdebug.remote_enable On On
xdebug.remote_handler dbgp dbgp
xdebug.remote_log /var/log/xdebug_remote.log /var/log/xdebug_remote.log
xdebug.remote_mode req req
xdebug.remote_port 9000 9000
xdebug.scream Off Off
xdebug.show_exception_trace Off Off
xdebug.show_local_vars Off Off
xdebug.show_mem_delta Off Off
xdebug.trace_format 0 0
xdebug.trace_options 0 0
xdebug.trace_output_dir /tmp /tmp
xdebug.trace_output_name trace.%c trace.%c
xdebug.var_display_max_children 128 128
xdebug.var_display_max_data 512 512
xdebug.var_display_max_depth 3 3


XML Support active
XML Namespace Support active
libxml2 Version 2.7.6


XMLReader enabled


XMLWriter enabled


XSL enabled
libxslt Version 1.1.26
libxslt compiled against libxml Version 2.7.6
EXSLT enabled
libexslt Version 1.1.26

Zend Debugger

Expose Zend Debugger always
Passive Mode Timeout 20 seconds
Connector PID 3996

Directive Local Value Master Value
zend_debugger.allow_tunnel no value no value
zend_debugger.deny_hosts no value no value
zend_debugger.expose_remotely always always
zend_debugger.httpd_uid -1 -1
zend_debugger.max_msg_size 2097152 2097152
zend_debugger.tunnel_max_port 65535 65535
zend_debugger.tunnel_min_port 1024 1024
zend_debugger.use_fast_timestamp 1 1
zend_debugger.xdebug_compatible_coverage 0 0


Zip enabled
Extension Version $Id: php_zip.c 294817 2010-02-09 17:51:39Z pajoye $
Zip version 1.9.1
Libzip version 0.9.0


ZLib Support enabled
Stream Wrapper support compress.zlib://
Stream Filter support zlib.inflate, zlib.deflate
Compiled Version
Linked Version

Directive Local Value Master Value
zlib.output_compression Off Off
zlib.output_compression_level -1 -1
zlib.output_handler no value no value

Additional Modules

Module Name


Variable Value
PATH /usr/local/bin:/usr/bin:/bin
PWD /media/kaltura/app_eagle_2011_11_22/generator

PHP Variables

Variable Value
_REQUEST["__utma"] 120182162.540143125.1297345532.1330623565.1330731780.330
_REQUEST["__utmz"] 120182162.1297345532.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none)
_REQUEST["uv"] uv_001c2e2aa3b03edb32ef7a94f8480d64
_REQUEST["__utmc"] 120182162
_REQUEST["ZDEDebuggerPresent"] php,phtml,php3
_REQUEST["PHPSESSID"] r3pca4utdrgbbsa60li83o4lm2
_REQUEST["__utmb"] 120182162.2.10.1330731780
_COOKIE["__utma"] 120182162.540143125.1297345532.1330623565.1330731780.330
_COOKIE["__utmz"] 120182162.1297345532.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none)
_COOKIE["uv"] uv_001c2e2aa3b03edb32ef7a94f8480d64
_COOKIE["__utmc"] 120182162
_COOKIE["ZDEDebuggerPresent"] php,phtml,php3
_COOKIE["PHPSESSID"] r3pca4utdrgbbsa60li83o4lm2
_COOKIE["__utmb"] 120182162.2.10.1330731780
_SERVER["SCRIPT_URL"] /api_v3/phpinfo.php
_SERVER["SCRIPT_URI"] http://kaltura.ubuntu/api_v3/phpinfo.php
_SERVER["HTTP_HOST"] kaltura.ubuntu
_SERVER["HTTP_USER_AGENT"] Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20120216 Firefox/3.6.27
_SERVER["HTTP_ACCEPT"] text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
_SERVER["HTTP_ACCEPT_CHARSET"] ISO-8859-1,utf-8;q=0.7,*;q=0.7
_SERVER["HTTP_COOKIE"] __utma=120182162.540143125.1297345532.1330623565.1330731780.330;   __utmz=120182162.1297345532.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none);  uv=uv_001c2e2aa3b03edb32ef7a94f8480d64; __utmc=120182162;  ZDEDebuggerPresent=php,phtml,php3; PHPSESSID=r3pca4utdrgbbsa60li83o4lm2;  __utmb=120182162.2.10.1330731780
_SERVER["PATH"] /usr/local/bin:/usr/bin:/bin
_SERVER["SERVER_SIGNATURE"] <address>Apache/2.2.14 (Ubuntu) Server at kaltura.ubuntu Port 80</address>
_SERVER["SERVER_SOFTWARE"] Apache/2.2.14 (Ubuntu)
_SERVER["SERVER_NAME"] kaltura.ubuntu
_SERVER["DOCUMENT_ROOT"] /var/www/kaltura/app/alpha/web
_SERVER["SERVER_ADMIN"] [no address given]
_SERVER["SCRIPT_FILENAME"] /var/www/kaltura/app/api_v3/web/phpinfo.php
_SERVER["REQUEST_URI"] /api_v3/phpinfo.php
_SERVER["SCRIPT_NAME"] /api_v3/phpinfo.php
_SERVER["PHP_SELF"] /api_v3/phpinfo.php
_SERVER["REQUEST_TIME"] 1330731799
_ENV["APACHE_PID_FILE"] /var/run/
_ENV["PATH"] /usr/local/bin:/usr/bin:/bin
_ENV["APACHE_RUN_USER"] www-data
_ENV["PWD"] /media/kaltura/app_eagle_2011_11_22/generator

PHP License

This program is free software; you can redistribute it and/or modify it  under the terms of the PHP License as published by the PHP Group and  included in the distribution in the file:  LICENSE
This program is distributed in the hope that it will be useful, but  WITHOUT ANY WARRANTY; without even the implied warranty of  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
If you did not receive a copy of the PHP license, or have any questions about PHP licensing, please contact

Comment actions Permalink


You can't use Xdebug and Zend Debugger extensions simultaneously. Please try to disable Zend Debugger extension.

Thank you for feedback!

Comment actions Permalink

Thanks Nikolay.
It's working perfectly now!

Comment actions Permalink


I am experiencing a similar issue, and have tried the suggestions in this post without success.
I really like phpstorm and want to recommend it for general use in our company (big multinational) but after wrestling for several hours (very frustrating), I cannot get the debugging to work - a real showstopper. Judging from the forums, the complexity of getting the debugger to work with phpstorm is a major issue. Phpstorm rocks, but you have to make this debugger config simpler!

My problem:

Debugging does not stop at breakpoints.

Debugger message in PHPStorm reads: waiting for incoming connection with session id '12441'

Xdebug website reports that xdebug IS installed.

My phpinfo():


xdebug support enabled

Version  2.1.4

Supported protocols Revision

DBGp - Common DeBuGger Protocol  $Revision: 1.145 $

Directive Local Value Master Value

xdebug.auto_trace Off Off

xdebug.collect_assignments Off Off

xdebug.collect_includes On On

xdebug.collect_params 4 4

xdebug.collect_return On On

xdebug.collect_vars On On

xdebug.default_enable Off Off

xdebug.dump.COOKIE no value no value

xdebug.dump.ENV no value no value

xdebug.dump.FILES no value no value

xdebug.dump.GET no value no value

xdebug.dump.POST no value no value

xdebug.dump.REQUEST no value no value


xdebug.dump.SESSION no value no value

xdebug.dump_globals On On

xdebug.dump_once On On

xdebug.dump_undefined Off Off

xdebug.extended_info On On

xdebug.file_link_format no value no value

xdebug.idekey ewoolf no value


xdebug.max_nesting_level 100 100

xdebug.overload_var_dump On On

xdebug.profiler_aggregate Off Off

xdebug.profiler_append On On

xdebug.profiler_enable Off Off

xdebug.profiler_enable_trigger On On

xdebug.profiler_output_dir C:\PROGRA~1\EASYPH~1.9\xdebug\profiler C:\PROGRA~1\EASYPH~1.9\xdebug\profiler

xdebug.profiler_output_name cachegrind.out.%s.%t cachegrind.out.%s.%t

xdebug.remote_autostart Off Off

xdebug.remote_connect_back On On

xdebug.remote_cookie_expire_time 3600 3600

xdebug.remote_enable On On

xdebug.remote_handler dbgp dbgp


xdebug.remote_log no value no value

xdebug.remote_mode req req

xdebug.remote_port 9000 9000

xdebug.scream Off Off

xdebug.show_exception_trace Off Off

xdebug.show_local_vars On On

xdebug.show_mem_delta On On

xdebug.trace_format 0 0

xdebug.trace_options 0 0

xdebug.trace_output_dir C:\PROGRA~1\EASYPH~1.9\xdebug\trace C:\PROGRA~1\EASYPH~1.9\xdebug\trace

xdebug.trace_output_name trace.%t trace.%t

xdebug.var_display_max_children 128 128

xdebug.var_display_max_data 512 512

xdebug.var_display_max_depth 3 3

My php.ini:

zend_extension = "C:\PROGRA~1\EASYPH~1.9\\xdebug\php_xdebug-2.1.4-5.3-vc9.dll"
xdebug.remote_autostart = false
; added ecw Thu 03/29/2012 09:18


My setup could not be simpler:
Local WAMP server (EasyPHP 3) and local development in the www root folder.

I have attached my phpstorm debug config (which seems to be working) and the actual php file I am using.

Other notes:
1. I am an application programmer - I am not so experienced with these settings
2. I remember seeing a question in phpstorm about xdebug or zend debugger - no idea where to find that now...
3. Nikolay made  a comment abouut having to disable zend debugger: I have no idea what that means. What do I need to do?
The xdebug website instructions say set:
zend_extension = "C:\PROGRA~1\EASYPH~1.9\\xdebug\php_xdebug-2.1.4-5.3-vc9.dll"
which I have done and xdebug seems to be working - is this correct?
4.I have tried several suggestions in other posts:
xdebug.remote_connect_back=On (I also tried xdebug.remote_connect_back=1) - made no difference.
5. I am using latest EAC release candidate - I had no choice, the version I downloaded from main site did not recognize my local functions or include_once references and reported "not found" all the time - unusable.

This has been a long post, but I figure you'd rather have the complete picture.

Please understand: I have put in much effort and would really like to get this resolved so that I can introduce your product into our company.

Thank you,


Phpstorm -debugger not working.doc
Comment actions Permalink

I forgot to mention:

I have run in firefox and clicked on generate, then on Start debugger link.

Comment actions Permalink

Hi Ed,

Judging from the forums, the complexity of getting the debugger to work with phpstorm is a major issue.

Most of the time it has nothing (or very little) to do with PhpStorm -- it's improperly configured (or not even installed) xdebug. Just today I was replying to somehow similar thread

  1. Before debugging web app/page, it is better to try to debug some very simple and basic PHP script in CLI mode (PHP Script type of Run/Debug configuration) -- this way is much easier to check if xdebug configured correctly.
  2. To check if you have more than 1 debugger extension installed, please check the output of phpinfo() function (this info will be in the bottom of the header)
  3. Have you seen this articles yet? They should provide enough info for setting up debugger in PhpStorm:

So far xdebug config seems to be OK. Try settings up value for xdebug.remote_log -- this will help with decising if xdebug is trying to connect to PhpStorm or not (and if it does, what the possible reason may be -- not responding, declined).

Comment actions Permalink

Hello Ed,

Do you still have the issue?

Thank you for feedback!

Comment actions Permalink


Thanks for assistance!;)

Comment actions Permalink

Hi Nikolai,

Thanks for the follow-up.

The problem is not solved - I gave up in frustration - could not get past the "waiting for input" message in the debugger. I even tried changing ports from 9000 after telnetting to find open ports - all in vain.

So maybe the issue is related to my laptop's security and windows.

I also have a LAMP setup on an Amazon Web services (AWS) EC2 cloud and was going to try again but then I read this article:

- seems to be similar problem?

I'm not able to spend the time testing (again) so:

If you can point me to clear instructions on using  phpstorm and xdebugger on a remote linux server, I'll have a look, otherwise, I'm afraid it's back to eclipse!

Comment actions Permalink

Hi there,

The stackoverflow thread you mentioned -- the same thread here:

So maybe the issue is related to my laptop's security and windows.

If that is the case then disable firewall .. or grant full network access for PhpStorm. Also, I hope you are not running PhpStorm and other PHP IDE at the same time (2 different applications cannot listen on the same port:ip pair).

If you can point me to clear instructions on using  phpstorm and xdebugger on a remote linux server

Is this "remote linux server" next to you (same LAN) .. or it's on internet. If second -- you will have to use port forwarding on your router and/or deal with ssh tunelling (maybe even xdebug proxy, dunno).

For  "clear instructions" you have to clearly describe your setup (in  details). But ... if you cannot solve local debug (web server is on the  same computer as IDE), then I see no much point jumping straight into  remote debugging: easier part first and then more complex stuff.

  1. First local CLI debugging (easier to initiate xdebugger -- no need to mess around with different approaches)
  2. Then local WebServer debugging
  3. Then Remote

Usefull to have (for Nikolay to give you better advice):

Comment actions Permalink

Hi Andriy,

I appreciate the prompt response. Sadly I do not have the time resources this week.

I will be installing onto a different laptop next week, and will revert on my progress. I'll look at the links.

It is a very common requirement to debug on a remote server, and if this is more complicated case, then I may be out of my depth here.

FYI The Amazon Web Service instance is a virtual dedicated box, i.e. I have bash and ftp access and can pretty much control it.
I don't have advanced skills on port tunnelling.



Comment actions Permalink

Hi Ed,

It is a very common requirement to debug on a remote server, and if this is more complicated case, then I may be out of my depth here.

From PhpStorm side the change between Local WebServer debug and Remote WebServer debug is minimal -- depending on your project setup it can be just 1 single setting change (like, host name etc), but configuring your remote server (xdebug) and your own pc/network (firewall, router port forwarding/ssh tunneling etc -- depends on your remote server) is a different thing that has no relation to PhpStorm (as it can be any IDE here).

That's why I suggest to start from making local CLI mode (PHP Script run configuration type) debug working first -- this will ensure that xdebug is configured properly + you will know what needs to be done in PhpStorm to make it work. Once you have done that you should have no issues with continue further (yeah, initiating debug session for web server debug is a bit different, but there are at least 3 ways of doing it in PhpStorm). All this needs to be done on brand new and very simple project (1 or 2 simple scripts to start with).

On related note -- check this thread (when you will have time, of course):
And then continuation:

Comment actions Permalink

Hi, Ed,

Do you still have the issue?

Thank you for feedback!

Comment actions Permalink

Hi Nikolay,

I do still have the issue.

I recently changed jobs and just yesterday I tried to get xdebug working again in my new environment.

My issue is simple: the debugger does NOT stop at any breakpoints. It's very very frustrating.

The debugger in PHPStorm shows I am connected to my server. I have tried checking and unchecking enable path names for the server - no difference - still no stop on breakpoints. Reveal log in explorer shows idea.log is empty (?) - I deleted it to clear out other crap before I started latest tests but expected it to show something?

My current config is ubuntu remote server running php 5.3, xdebug is enabled for an older version: I am not in a position to change the php server environment.

My php.ini:

This program makes use of the Zend Scripting Language Engine:

Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

    with Xdebug v2.1.2, Copyright (c) 2002-2011, by Derick Rethans

It might fix things to change php server xdebug settings and latest install but I see on the forums that some others are having the same issue of the debugger not stoppng at breakpoints. Xdebug developer Derick Rethans said he just released a RC of xdebug to address this but user said didn't work. In fact, latest release of xdebug seems to have stability problems, judging from the bug list, so:

I am going to keep monitoring the forums (xdebug and this one) but will hold off trying to get this working until xdebug settles down again. I can't afford to get bogged down on this issue in a new job :-)

I really think that PHPStorm is an excellent product and your support has been excellent too. That's why I want to get the damn debugger working!!

In truth, though, the interface to set up the server and debugger needs to be redone  - there are so many paths to set up to map server and client - very confusing and what each setting is for is really not properly explained. I was wondering: what's this for now? a lot of times! A few example configuration would help enormously, but frankly the whole config is overly technical (in the interests of being flexible I know, but simply serves to confuse here) and needs to be greatly simplified.
I would be happy to assist you with the documentation- but first I need to get the product working so that I can use it at work first.

If there is any further news of the Xdebug issue, I know you will keep me posted :-)

Best regards

Comment actions Permalink

Hi, Ed,

Please provide your Xdebug remote log ( I really need to dive into your issue.

Thank you for feedback!

Comment actions Permalink


Any progress here?

Thank you for feedback!


Please sign in to leave a comment.