Horizontal line above class definition

Does anyone know how to remove the horizontal line that appears across the editor that shows immediately above the class definition? I've performed a search for many settings, hoping to find it.

5 comments
Comment actions Permalink

Hi David,

You cannot remove it. But you can "hide" it by changing color for that element (make it the same as background) -- Settings | Editor | Colors & Fonts | General | Method Separator Color

0
Comment actions Permalink

That was perfect, thanks!

0
Comment actions Permalink

I'm using PHP with Intellij. Under <?php i have a horizontal line. How do I get rid of this? I unchecked 'Show method separators', but it's still there.

0
Comment actions Permalink

@Yendrrek

As stated 2 comments above: you will have to change the Color Scheme for that, Method Separator color in particular.

https://stackoverflow.com/a/17697003/783119

I'm not using IntelliJ but it should work the same there (as they are both IDEA-based IDEs).

0
Comment actions Permalink

Thank you, that worked.

0

Please sign in to leave a comment.