Upgrading to WebStorm 4.0 in OSX - cannot import settings from 3.0.3

Hi all,

This is my first upgrade of a JetBrains product. I followed the instructions emailed to upgrade my copy of WebStorm to 4.0. The first thing that has popped up is the "import settings" dialog:

webstorm import dialog.jpg

"/Applications" is the default value in the entry box (I didn't enter it), and is also where I allowed both WebStorm versions to be installed.

When I click OK, I get this error:

"/Applications does not appear to be WebStorm config folder or installation home"

I would like my settings to be imported, so the second option is no good to me. Has anyone else hit this problem before? Is this a bug, or do I need to export my settings from WebStorm 3.0.3 before I can upgrade?




OK, I worked this out:

1) Clicked the "I do not have a previous version of WebStorm" option and allowed the installation to complete.
2) Opened WebStorm 3.0.3, which fortunately had not been overwritten by the installer. (at which point I got an upgrade notification, it would have been nice if the email told me this!)
3) Ignored the upgrade message and exported the settings from this version
4) Closed WebStorm 3.0.3 and opened WebStorm 4
5) Imported the settings file

Hope this helps someone else in future.


Hi Sean,

v1, 2 & 3 have their settings in folders named .WebIde10 (e.g. ~/Library/Preferences/.WebIde10 )
v4 on another hand has its settings stored in .WebIde40

TBH -- I have no real idea what path you have to provide there since I'm not a Mac user and if I would be upgrading I would rather use the same what you did (File | Export / Import Settings ...) .. or just copy those files manually (since I know where to look for them -- IDEA file locations: http://devnet.jetbrains.net/docs/DOC-181 )


Just an FYI,
This is also happening for me on Windows 7  v3.0.3 to 4.0 build 117.222.
Not sure what path it wants but nothing I entered worked.  I finally just gave up and did the export/import thing.




If you want the actual folders for this dialog, try this:

  • Mac OS -- ~/Library/Preferences/WebIde10
  • Windows 7 -- C:\Users\USERNAME\.WebIde10\config
  • Windows XP -- similar to Windows 7 -- C:\Documents and Settings\USERNAME\.WebIde10\config
  • Linux -- (I guess) ~/.WebIde10

maybe there are differences between the installation from  WebStorm and PhpStorm. I've got the same "problem" with PhpStorm  (http://devnet.jetbrains.net/message/5457501#5457501)
But with the help from : Andriy

v1, 2 & 3 have their settings in folders named .WebIde10 (e.g. ~/Library/Preferences/.WebIde10 )
v4 on another hand has its settings stored in .WebIde40

the import works fine.

So I hope with WebStorm 4.0 it's the same, and all OS X users will find an easy import.

Maybe it would be a good idea, to write something like this (try  "~/Library/Preferences/.WebIde10" as directory) in the error-print of the install/import-process for OS X. It would help and free Andriy's, other moderators, or experienced user's Power for more tricky problems...



Thanks Andriy, I tried "/home/user/Library/Preferences/.WebIde10" at the time, but it complained about a missing jar file - "settings.jar" I think it was called.

The only thing that worked for me was exporting the settings first from the old installation, and importing the result.

Certainly the default value "/Applications" appears to be wrong, from what you and others have said on this thread. I'll file a bug.


I've filed a bug, please star and/or comment on the report if this issue affected you.



Please sign in to leave a comment.