PHPStorm crashed and I lost my 'upload to' settings

Hi, until today it was all fine working and I could right click a file and select 'upload to' and then select a server.
This option is gone after the Software crashed today.
I can't re-setup this for one reason.
I have my remote host working and accessable but the 'upload to' option is not visible as well as the 'download from here', 'download to here' and the 'compare remote file with local''
What setting I have to do? Please advice!


Hi Heidi,

To start -- please check if "Remote Hosts Access" is enabled in Settings | Plugins.

Then check Settings | Deployment -- check if all is fine there.

Then check Settings | Deployment -- check if all is fine there.

Did you checked that -- is all settings are OK for your default deployment server?


Well -- let's try this:

  • Close PhpStorm
  • Open your project folder and rename (or backup and delete) .idea subfolder (this project settings)
  • Open PhpStorm and using "File | Open Directory" open that folder and configure Deployment again
  • Check if that option is back

Instead of doing the above you could create brand new project and setup deployment there and see how it goes -- up to you.

If that will not help, then it looks like some file with IDE-wide settings got corrupted because of crash (not sure, though)



Looks like you've lost mappings in remote host's configuration or excluded some path on server. Please check mappings and excluded paths in Tools | Deployment | Configuration. Then open Remote Host (Tools | Deployment | Browse Remote Host), choose your server and check all paths you want to download from or upload to are green. That means they are mapped to local file and are not excluded.


Yes!! The mapping was not correct anyomore. Remote files were not green anymore! Thanks for this helpful tip! Now I can continue working! Great and fast support! Thanks!!


This happened to me after I checked Sync Plugins Silently which I thought would UPDATE plugins behind the scenes, when it seems it synced what plugins were active/inactive. I guess my "could" settings had a ton of plugins disabled, including remote configs, FTP, SFTP, etc. 


Please sign in to leave a comment.