Cannot delete file - filename starting with slash after using uml

Hello,
yesterday I tried uml-diagrams for the first time in phpstorm.
Now I have a big problem.
After saving a diagramm to an uml-file I cannot delete the uml-file anymore.
The problem is quite strange:

I made the mistake that I used the given filename from phpstorm - that one was starting with a slash!
So the file was saved as /agBlog.uml and not agBlog.uml.
Yes, you hear right: The fileNAME contains a slash.
Finder and Fileexplorer (on mac) do not show this file.
But the fileexplorer in phpStorm shows a file named /agBlog.uml (yes, with the slash); that one is writeprotected and I cannot remove that file.


Who can help? Seems to be a real deep bug.

Thanks, Adrian.

1 comment
Comment actions Permalink

Ok, I solved this problem for myself, but here how I did it for all who might get into this problem:

1. In phpStorm I created another uml-File with the same name WITHOUT the slash in front of the filename.
2. Then the write-protection of the file WITH the slash gets automatically switched off, so you can DELETE the file WITH the slash in front using the phpStorm-Fileexplorer.
3. Then there is still the uml-file without the slash in front. If you tried to delete it now, you would get an error, because the file does not exist in your file system but only in phpStorm, so you have to do the following:
4. Use your normal system file explorer and go into the directory where the uml-file should be located.
5. Create any file (or copy any file) and rename it to the name of the uml-file like shown in phpStorm, e.g. agBlog.uml (WITHOUT A SLASH!)
6. Go back to phpStorm-File-Explorer. Now you can delete the uml-File.

Done.
This is a bug (maybe only for mac versions) in phpStorm, I think. I do not understand why a filename can contain a SLASH? I thought this is forbidden by the filesystem?

Best regards, Adrian.

0

Please sign in to leave a comment.