Webstorm - can I reset to the "bundled" plugin

I wanted to use the JSTestDriver in Webstorm and so first went to the JSTestDriver downloads site get the latest version.

My steps were

1) Download version 1.4 of the plugin from http://plugins.intellij.net/plugin/?webide&id=4468. From version 111 until version 113 (mine is 111.19)

2) On Webstorm, Plugins select JSTestDriverPlugin and click Install plugin from disk

3) Locate the downloaded folder, and select JsTestDriver-plugin.jar (timestamp 21-Feb 16:14)

4) Once I'd done this I started to get errors

java.lang.NoClassDefFoundError: com/google/inject/Provider

Rather than spend time troubleshooting the problem, I'd prefer just to go back the the version bundled with Webstorm 3. I tried reinstalling Webstorm, but the new plugin prevailed.

Does anyone know how I can reset the plugin to the bundled version?



Webstorm 3.0, Build #WS-111.19


for phpstorm 4 C:\Users\<username>\.WebIde40\config\plugins

probably be:

(this is on windows.. no idea where it is on mac.. check your config folder)


Thanks, William. Your answer gave me enough information to proceed.

It turns out that Webstorm comes with a list of bundled plugins, and any "overrides" to these are stored in a plugins directory, in my Mac case: ~/Library/Application Support/WebIDE10 (refer http://www.jetbrains.com/webstorm/webhelp/project-and-ide-settings.html).

The jar I had loaded was there, and once I deleted it the plugin status reverted to "bundled" (and the plugin worked again)



Please sign in to leave a comment.