SSL https web path/project URL

PHP Storm does not let me enter a project URL with https://. This means that when I click to to the website from PHP Storm, it takes me to the http version which doesn't contain any files on my servers.

Is there a way to over-ride or allow https:// within the Project URL field when setting up a new project on a remote server?

Thanks!

4 comments
Comment actions Permalink

Are you talking about deployment settings or debbugging setup? Please provide more context for "PHP Storm does not let me enter a project URL with https://"

0
Comment actions Permalink

Hi Todd,

I assume you are talking about Deployment. If so -- this is a know issue: http://youtrack.jetbrains.net/issue/WI-3033?projectKey=WI

Please check the last comment on the issue for a way to by-pass such current restriction.

0
Comment actions Permalink

Thanks, I am referring to the deployment settings.

I looked at the thread you posted and the last comment but I don't find a setting like the one mentioned. Can someone explain in a little more detail? Thanks!

0
Comment actions Permalink

Hi Todd,

  1. Run | Edit Configurations (or use dropdown box on main toolbar, the one just before Run and Debug buttons).
  2. Here you can create new entry of "PHP Web Application" and "Start URL" field will accept https protocol.
  3. After creating it, use aforementioned dropdown box to select the configuration and then use "Run" to open that URL in browser.
0

Please sign in to leave a comment.