Phing Issue

I had phing working perfectly untill  I installed PHPStrom 3.0 now I get this weird errror when I run my phing scripts
Not sure what the issue is phpdoc.PNG



Attachment(s):
phpdoc.PNG
15 comments

Hi Edgar,

Please check comments in this ticket -- maybe you have similar situation: http://youtrack.jetbrains.net/issue/WI-8948?projectKey=WI

0

Hi sorry for the late response. So I am having the same issue as the guys in that link but I have to tell you am on a brand new machine
Innoticed they said to add the PHP_COMMAND variable in the system variables nbut I am not sure what the value of that is supposed to be. Is it suppsed to be the path to PHP command line?
its funny because I had this all working perfectly in phpstorm 2.x EAP and as soon as I switched to 3.0 Phing doesnt work any more. Any other ideas?

0

As I understand phing is invoked differently in v3 compared to v2.

If you run cmd.exe and execute PATH (e.g. C:\Users\Edgar>PATH <ENTER>) -- do you see path to php.exe there? If not -- you need to add it it there (for Windows 7): Computer -> Properties -> Advanced System settings -> Environment Variables -> System variables -> Path

0

yeah I had that variable in the path but it wasnt working. I am following the instructions again. Will post back in abit andf let you know how it all goes. Going to set allt he paths for a manual phing install

0

yeah its not working. here s a screen shot of my enviroment variable
BTW my PATH includes C:\xampp\php\php.exe I added right after I took this image. Everything else is the same.if I navigate to a folder where my phing build.xml file is I can type this in the command line
C:\Path\To\My\File>phing

this command willl look for the build file in the current folder and then run that build file. so phing works in the command line
I still have PEAR installed, is that an issue ?

vars.PNG



Attachment(s):
vars.PNG
0

Edgar,

Do you still having the same error? Or is it different this time?

If error is still the same then try restarting your PC (or at least logoff & logon again). If you have applied these variables to System variables and not User variables, it may not be visible until restart.

For me -- I had path to php.exe already in the PATH .. and I do see completely different error -- PhpStorm searches for phing.php file in wrong directory .. but in configuration it asking for phing.bat -- confused here. Phing installed via pear and is working fine from command line.

From what I see:

  • PhpStorm is unable to run phing if it is installed via PEAR.
  • PhpStorm can only handle phing if it was installed manually, as it requires /bin folder, which is present in manual installation type only.
0

I have created the following ticket for PhpStorm to support phing when installed via PEAR:


If you install phing manually (not via PEAR) and do all the configuration as described in manual, then it works just fine:

0

thanks for starting the ticket. I will report back after i do a reboot I am in the  middle of a backup. Might take an hour or so to finish and then again its Christmas eve-eve. Anyways Thank you I will post back after I reboot. I am really hoping it takes affect I loved the Phing plugin in PHPStorm 2.x
BTW yes I am still getting the original error. Same error through and through. Argh :(

0

OK I rebooted but nothing has changed :_|

0

I think you doing something wrong with setting up PATH variable. Can you please show how it looks right now (not just System or User variables, but both).

In my opinion %PATH%;%PHING_HOME%\bin value is wrong if defined there -- it only makes sense if assigned dynamically / from command line. If defined on that screen it should contain real paths only and not contain reference to itself (e.g. C:\xampp\php;C:\phing\bin;...). I've tried defining PATH on that screen in the same way you did (User variables section) and it resolved %PATH% and %PHING_HOME% to real paths as soon as I clicked OK button. If you have altered existing PATH in System variables section ... then most likely it is unable to reference to itself and it does not work (but then you may have issues with whole Windows).

Just execute PATH from command line and see if you see all these required paths there.

Or better -- just execute php.exe from some random location (e.g. Start -> Run) and see if it will find it.

I think this is unrelated to your current issue, but have a look (if you have not done it already) -- a note about XAMPP:

0

First off, thank you ffor your help, its very nice to have your help.
#2 I will post th info you requested in justa  bit.

0

Well all the paths are there. So I'm still not sure what the issue is. I also in the past tried to just make them the whole paths rather than the references. BTW I added these vairiables not to the syste, paths but to the user paths. Maybe I have to add them to the system paths instead of te user paths? Whats your take?

path.PNG

0

Well -- your PATH definitely needs cleanup -- some entries (folders) are repeated 3 or 4 times.

But back to the topic: C:\xampp\php\php.exe is INVALID path: it should be folder only and not full path to the specific file. Replace C:\xampp\php\php.exe by C:\xampp\php

0

O My God !
I feel dumb!
OK so what fixed it was just to remove the php.exe from the path
you were right.
User Error here.
Anyways thank you again and Merry Christmas.

0

I had the same error but the reason for me was the value being quoted:

PATH=C:\pear;"C:\Program Files\Zend\ZendServer\bin";C:\Program Files\Zend\ZendServer\share\ZendFramework\bin

0

Please sign in to leave a comment.