6 comments

Please answer me, why I don't see any folders in my project. There are folders in the same folder, if I open the "project-folder" in my filemanager.

0

Please show a screenshot of Project View panel -- maybe you just using different view/scope?

Check this thread first: http://devnet.jetbrains.net/thread/432468?tstart=0

P.S.
You can always "fix" it by deleting .idea subfolder (project settings are stored there)  and then re-creating the project from scratch in PhpStorm (obviously, project must be closed when deleting .. and make a backup of that folder, just in case).

0

Thank's for your reply.

Please show a screenshot of Project View panel -- maybe you just using different view/scope?


Please see my attached screenshot.

Check this thread first: http://devnet.jetbrains.net/thread/432468?tstart=0


I've checked that, but that's a different problem. I haven't pressed any buttons at project open-task. I cannot see any folders in EVERY project.

P.S.
You can always "fix" it by deleting .idea subfolder (project settings are stored there)  and then re-creating the project from scratch in PhpStorm (obviously, project must be closed when deleting .. and make a backup of that folder, just in case).


I know about that. But this workaround isn't good. If I save something in my folder, I have the .idea folder and the next time I have to repeat this stupid task. There must be a normal workflow.



Attachment(s):
project-view.gif
0

Similar/related tickets:


I saw similar screenshot on some another ticket (was MacOS as well) .. but unable to find it right now.

In any case -- if it's affecting ALL projects .. then I suggest backing up PhpStorm settings (via "File | Export Settings" for example .. or manually: ~/Library/Preferences/WebIDe10, I guess) then delete them so PhpStorm will recreate defaults on next run -- maybe it's something to do with configuration (corrupted file or something) or maybe even some plugin. Not sure at all if this will help, but at least worth trying.

0

Thank's for this workaround! I've deleted the folder $HOMEDIR/Library/Preferences/WebIDe10. Then I've started PhpStorm, entered my license and opened some already created projects and created new projects. The subfolders where visible everywhere! Thanks!

0

Please sign in to leave a comment.