.lib suffixed folders are hidden by PhpStorm

Any folder which name ends with ".lib" within the open project is not shown under project folders list.

How to reproduce:

- Create folders of the following structure in your filesystem:

- project1
-- a.lib
-- b.lib

- Try to create a project from "project1" folder File -> Open Directory

Expected:
- You can see folders in your newly created PhpStorm project

Actual:
- No folders are shown under root "project1" folder

UPD: While this forum was submitting this post, I created a bug http://youtrack.jetbrains.net/issue/WI-9236

1 comment

Hi there,

Settings | File Types --> Ignore files and folders (the input box on the very bottom) -- it contains *.lib pattern. Remove it if you want your a.lib, b.lib folders to be included.

0

Please sign in to leave a comment.