indentation keeps going in

For some reason, after upgrading to the latest version of PhpStorm, I'm having strange problems with indenting.  If I don't do anything at all, my html looks like this:

<h1>Hello</h1>
      <h2>World</h2>
             <h3>I love indents</h3>
                     <h4>wtf mate</h4>




Sometimes it does it with my php too, I haven't noticed a pattern.

Does anyone know how to stop this from happening?  It really sucks...

1 comment
Comment actions Permalink

Possibly it's your Code Style (Formatting) settings as I do not have such behavior. Please attach them here so devs can look at them + describe exactly how it happens (what you do when this happens, e.g. "<h1></h1>, type the H1 text, move cursor to the end of line, press enter -- next line is indented; repeat the same for H2 -- same result" -- some screencast will be very useful here).

0

Please sign in to leave a comment.