Php debugging trought xdebug+dbgpproxy

Hi,

I was wondering if there was a way to launch a "PHP HTTP Request" or a "PHP Web Application" debug session when you are using xdebug with a DBGP Proxy.
The problem that I see is that the XDEBUG_SESSION_START variable passed to the server do not match the IDEKEY speficied in the Proxy setting but seems to be a random int ID.

Is there anything else that I'm missing ? The "PHP Remote Debug" is working right waiting for a debug connection with the specified IDEKEY and as soon as I call any page with the parameter XDEBUG_SESSION_START=MYIDEKEY everything is working fine.

Thanks for any help you can provide...

++ JF

3 comments
Comment actions Permalink

Hello Jean,

I was wondering if there was a way to launch a "PHP HTTP Request" or a "PHP Web Application" debug session when you are using xdebug with a DBGP Proxy.

It seems that these run configurations are unusable if you use dbgp proxy. Feel free to submit an issue if you need it - http://youtrack.jetbrains.net/issues/wi#newissue=yes. But I suggest you to try Zero-Configuration debugging feature before - http://blog.jetbrains.com/webide/2011/02/zero-configuration-debugging-with-xdebug-and-phpstorm-2-0/

The "PHP Remote Debug" is working right waiting for a debug connection with the specified IDEKEY and as soon as I call any page with the parameter XDEBUG_SESSION_START=MYIDEKEY everything is working fine.

Please note that you can also trigger xdebug using browser cookie (http://xdebug.org/docs/remote#browser_session). Try to use Xdebug bookmarklets to control Xdebug cookies.

Thank you for feedback!

0
Comment actions Permalink

Jean,

Do you still have the issue?

Thank you for feedback!

0
Comment actions Permalink

Jean,

Do you still have the issue?

Thank you for feedback!

0

Please sign in to leave a comment.