PHPStorm 3.0, Zend Debugger, Firefox fails to connect

I believe I have installed everything correctly, PHP debugging worked in 2.1 with this server.
Prior to the failure I moved the server to a new IP and Host Name, and upgraded PS to 3.0.
I reviewed and updated all relevant settings in PS and file synchronization on save is working as expected.
I have 'Run/Debug Configurations' > Break at first line Checked.

When I click 'Listen PHP Connections', then click 'Zend Start session' in firefox and reload the php page,
Nothing visible happens in PS.

I have the PS logging set as

 <category name="#com.jetbrains.php.debug">
 <priority value="DEBUG"/>
 </category>

 
At this point the relevant log entries are:

2011-12-11 23:36:51,660 [  67798]   INFO - il.connection.ServerConnection - StartingXDebug on port 9000
2011-12-11 23:36:51,662 [  67800]   INFO - il.connection.ServerConnection - StartingZend Debugger on port 10137
2011-12-11 23:36:51,663 [  67801]   INFO - il.connection.ServerConnection - StartingZend Debugger Settings Broadcasting on port 20080

These entries are made upon clicking the 'Listen PHP Connections' button, no new entries are made when I click 'Zend Start session' in Firefox.

If I click the 'Debug (server configuration name)' button, the debug window opens with an empty Console pane.
The Debugger pane shows "Waiting for incoming connection with session id 'PHPSTORM'"
The are no new entries in the log file.

When I reload the PHP page in the browser, nothing changes in the Debug Window and there are no new log entries.

When I click the 'Zend Start session' bookmarklet, and reload the page a bunch of cookies are set.


Any suggestions or assistance would be greatly appreciated.

Best,

-Glen

Configuration details:
----------------------

When I generated the Zend Debugger bookmarklets, I entered the IP address of the web server.

PHPStorm: #PS-111.19
Firefox: 8.0.1
Zend Debugger: v5.3
Workstation: Mac OS 10.6.8
WebServer: Ubuntu Server 11.0.4
Webserver is running in VMWare Fusion as a virtual machine

phpinfo() Zend Debugger
-----------------------
Expose Zend Debugger  allowed hosts only
Passive Mode Timeout  20 seconds
Connector PID  834

 Directive Local Value Master Value
zend_debugger.allow_hosts 192.168.1.0/24 192.168.1.0/24
zend_debugger.allow_tunnel no value no value
zend_debugger.deny_hosts no value no value
zend_debugger.expose_remotely allowed_hosts allowed_hosts
zend_debugger.httpd_uid -1 -1
zend_debugger.max_msg_size 2097152 2097152
zend_debugger.tunnel_max_port 65535 65535
zend_debugger.tunnel_min_port 1024 1024
zend_debugger.use_fast_timestamp 1 1
zend_debugger.xdebug_compatible_coverage 0 0

2 comments
Comment actions Permalink

The solution turnout to be the IP address entered into the Zend Debugger bookmarklet generator at
http://www.jetbrains.com/phpstorm/marklets/

I originally entered the remote server address, where Zend debugger was installed that did not work, as detalied above.
The localhost address, which is the default for the bookmarlet generator did not work for me.
The correct address was the IP assigned to my workstation, where PHPStorm is running.

Keep in mind that my 'remote' server is actually running on a virtual machine, that happens to run on my workstation.
This may confuse the issue, I don't know.

It would be very helpful if documentation on setting up Zend debugger would provide more information on what this adress should be.

Best,

-Glen

0
Comment actions Permalink

Glen,

Thanks for sharing!

It would be very helpful if documentation on setting up Zend debugger would provide more information on what this adress should be.

Do you expect to have this information directly on the bookmarklets page or in the separate document? We already have an Zend Debugger installation guide where this problem is clarified. Where have you searched an information about settings up Zend Debugger before?

Thank you for feedback!

0

Please sign in to leave a comment.