Plugin will not install

The Bitbucket plugin had an update today, So i accepted the update and restarted PhpStorm.
After a while I noticed the plugin wasn't active. So I looked at the plugin section in settings and the plugin is marked as [downloaded] and when I hover over it with my mouse it states it will be activated on next startup. However, no matter how often I close and reopen PhpStorm, the plugin does not install and remains [downloaded]. It also does not give me the opton to remove it, so I am stuck.
How do I "reset" this?

3 comments

Hi Evert,

Lets try this:
1) Please check these folders and delete plugin file(s) from there:

  • ~/.WebIde10/config/plugins  ( on Windows 7 it will be C:\Users\<USERNAME>\.WebIde10\config\plugins )
  • ~/.WebIde10/system/plugins

If you are on Mac -- folders most likely will be located in different places.

2) If you found and successfully removed plugin -- try installing it again.

Obviously, make backup before doing such manipulations (just in case).

0

Thanks for the reply. It didn't solve the problem, but it did provide me with an insight into one. After cleaning out those directories all my (previouly installed) plugins were showing as "downloaded" and refused to (un)install. So I restored those files back into the plugin directory and they seemed to be working again.
This gave me the idea to download the bitbucket plugin manually and move it into the plugin directory. This worked, it enabled me to uninstall the plugin and then reinstall it again. Problem solved.

0

Hi,

PhpStorm 3.0.1 will bring you couple of fixes related to plugins configuration. First EAP builds will be published shortly.

Regards,
Kirill

0

Please sign in to leave a comment.