My project get's lost in the 3.0

Hey,

I'm currently having a problem with the new PHP Storm 3.0.
I was working on a couple of projects the other day and when I opened them today all of the files in the project stopped showing inside PHPStorm.
The files are there, I can see them in my terminal but PHP Storm seems to be "blind" or something ?

I tried to "Invalidate and restart" but it doesn't help.
What seems to cause this problem ? The only solution to this  so far is to delete the .idea folder and start a new project.


tftd

4 comments

I managed to get the problem solved.
In order to fix this you need to go to YourProjectDir/.idea/modules.xml and change this:

<?xml version="1.0" encoding="UTF-8"?>
<project version="4">
  <component name="ProjectModuleManager">
    <modules />
  </component>
</project>



to this:

<?xml version="1.0" encoding="UTF-8"?>
<project version="4">
  <component name="ProjectModuleManager">
    <modules>
      <module fileurl="file://$PROJECT_DIR$/.idea/myProjectNameGoesHere.iml" filepath="$PROJECT_DIR$/.idea/myProjectNameGoesHere.iml" />
    </modules>
  </component>
</project>


You need to change "myProjectNameGoesHere" to your actual project name.
Then start PHPStorm and everything should be working fine again.

0

Hello tftd,

Thanks for sharing!

Most likely it was a result of using 'Remove Module' action. Please vote - http://youtrack.jetbrains.net/issue/WI-8927

0

the same issue happened twice for me. The last one, when project  openning process («Loading modules...», i suppose), and I accidentally pressed «ESC» key — after project  finally  loaded  project folders disappeared.
I am sure, that I didn't use «remove module» action.

0

Hey Nikolay,

Sorry for my late response. I haven't removed my module. I noticed, though, this problem occures if you "cancel"  the loading process of your project.
I tested it with the latest official version and things happen exactly as Argny Phy says.

Regards,
tftd


0

Please sign in to leave a comment.