Project view not showing directories

Somehow the Project view is not showing the directories for my Project?  It's as though it's treating the build.xml as the 'root' of the project and I'm not able to browse directories as I usually can.  I've tried invalidating the caches and restarting, no help.  Problem is not present for any of my other projects.



Attachment(s):
Screen shot 2011-12-20 at 11.22.52.png
16 comments
Comment actions Permalink

Further to this, the Project preferences for Directories won't load to show which directory the project points to.  See attached.



Attachment(s):
Screen shot 2011-12-20 at 11.40.01 (2).png
1
Comment actions Permalink

Check your idea.log -- it may have some details explaining why or what is happening (Help | Reveal log in Explorer). Possibly one of the config files got corrupted.

You can always backup and delete .idea subfolder (project settings) and re-create project from scratch. When it's wroking again (after basic configuration) you may copy some of the files from that folder back to recover some of your settings (if there were many).

3
Comment actions Permalink

Thanks, I didn't have to many settings, and deleting .idea then recreating the project has solved the problem.

0
Comment actions Permalink

Though, sorry, I didn't check the log before I deleted it... :( If it happens again I will do and report back findings if that would help.

0
Comment actions Permalink

Thanks, deleting the .idea directory worked for me. After that all the folder showed up again.

1
Comment actions Permalink

Is that it? No way to force reindex the project folder ... so every time I add a new folder I have to close the project, delete .idea then open the project again ??

0
Comment actions Permalink

@Leo

No idea. That delete option was offered as hard workaround for one time issue.

If it happens to you all the time.. then it must be something else and needs investigation. Contact Support Team by making Support Request -- use "Submit a Request" link at the top of this page.

1
Comment actions Permalink

Thanks, deleting the .idea directory worked for me too.

0
Comment actions Permalink

Switch to "Project Files" view instead of "Project" view. Done.!!!

5
Comment actions Permalink

Switch to "Project Files" view instead of "Project" view

Worked for this newb

2
Comment actions Permalink

To view all folders in explorer project view...
File -> Settings

Version Control -> Directories

Add content root to project root folder. All folders will appear in project

1
Comment actions Permalink

Issue still persists in PHPStorm 2020.2.

No directories found, Settings > Directories is empty ("nothing to show").

Deleting the .idea/workspace.xml file did the job for me. The re-created workspace.xml did not show any significant differences - however, re-creating the file also created a .idea/<project>.iml file which was missing before. So I suppose that's might be the core of the problem. Also, the inspectionProfiles folder was created after that, but I suppose that is just because previously my source folders were not available for indexing.

0
Comment actions Permalink

I think I found a simple solution that seems to work for me in PHPStorm. Yes, you can switch to the "Project Files" view, but that does not solve the problem of namespaces not being properly detected and "class not found" inspections in the IDE.  I tried invalidating the cache and restarting but that did not seem to help. I did not want to delete the .idea directory. On a whim, I tried closing the project via the "File-->Close Project" menu and re-opening it. This worked for me after all other methods failed. I didn't even have to restart the IDE. So, apparently manually closing and re-opening the project without restarting the IDE does something different than simply closing the window and restarting the IDE. 

7
Comment actions Permalink

You're definitely right, Brett. Thank you!)

0

Please sign in to leave a comment.