Configure DB Nvigator plugin in phpstorm 3

i want to know how to configure db navigator with mysql locally (WAMP). I dont know what to put in url, name, discription, user, password, driver, driver library  fields. Plz tell me about this in detail and i m using windows 7 with local server WAMP.

I also want to know how to connect db navigator to my remote server database. Plz tell

2 comments

First I setup the built-in Data Sources plugin to work with my local MySQL testing environment.

Enable the Data Sources in  setup->plugins  if it is not already showing in Phpstorm.

Activate the Data Sources Tab and press the + sign to setup a new DB Data Source.

Name the Data Source to something associated to the project or database you are going to be connecting to.
This is only for your purpose to identify it later, name it something descriptive.

Select the Database tab and from the JDBC Driver Files: drop down select "MySQL Connector / J5.1.18 (download)"

This will download the driver you need to connect to MySQL, I saved this file in a folder that is common to all my projects.
This driver will be used in ALL your MySQL connections via Phpstorm, any new connections you make in the future you will use this file.

Once the file is downloaded I press the button next to the JDBC Driver Files drop down and manually select the file that was just downloaded.

Next I choose

JDBC Driver Class:   com.mysql.jdbc.Driver
Database URL:   jdbc:mysql://
User Name:   username of database user
Password:   username password

Next I go through the other tabs and select how I want the database and tables to be displayed etc...

I do the above first, just so I have samething in both the Data Source and the DB Browser Plugin, plus this is how I downloaded the driver to be used.


Click on Test Connection and you should have a successful connection, then I click on Refresh Schema to load the database in, click OK.


Now I switch over to the DB Browser plugin and do the samething.

Click on the DB Browser plugin tab that appears on the side of Phpstorm, I don't remember where it is by default I moved mine to the right side at top.

Press the Settings button, it is the LAST button on the top right, next to Hide Object Properties.

Select the Connections Tab.

Press the + sign on the left side of the window, it is under the Scope drop down.

Check the Active box, you may only be able to do this after the settings are complete, I don't remember.

Name the connection, I named mine the same as I did in the Data Sources options above.

You can put in a description if you want, I left this blank.

Now you need to choose the driver file that you downloaded from the steps above.

Then in Driver:  choose  "com.mysql.jdbc.Driver"

URL:  I use ->  jdbc:mysql://

then the user and password for the database I am wanting to access.

I leave the Use OS Authentication check box blank, or unchecked.

Then click on "Test" button and it should have a successful connection.

The rest of the settings are personal as to how you want to show the information in the database and how much.

That is it.

I don't connect to a remote database using Phpstorm so I can't help you there.  I only use the software for local testing and development on my local testing environment.


Hope this helped you or at least someone that comes to this later.

0

In my last post I assume that you have the database all setup on your testing environment and you have a username and password associated to the database.

I have not been using the DB Navigator plugin due to it crashing the Phpstorm UI everytime I try to use it.  Instead I just use the built-in Data Sources feature and also a 3rd party software HeidiSQL which is much improvement over PhpMyAdmin.

I am not sure why but I use PhpMyAdmin and HeidiSQL a lot more than I do the built-in database features of PhpStorm or the DB Navigator plugin, when it worked.

I have tried to report the bug to the developer via the tracking feature of jetbrains site but I can't login to that for some reason, contacted support several times about it but never got a response or resolution so I just don't report bugs, I can't anyway.  LOL

0

Please sign in to leave a comment.