Xdebug proxy: Cannot connect to xdebug prox on ....:9000

Hello.
I just tried out phpStorm EAP 3.
When I tried to establish Debug on a remote linux server, phpStorm is not able to establish a conection with the xdebug proxy.
I checked phpinfo: the newstest xdebug version is correctly installed.
I checked the IDE-KEY: same.
Everything seems right configured but it does not connect.
When I used 2.4 everything was fine... so... can somebody help me?

This is my xdebug.ini file in my conf.d folder of /etc/php5/apache2/:

zend_extension = /usr/lib/php5/20090626/xdebug.so
xdebug.remote_enable = 1
xdebug.remote_port = 9000



I have to put it in this xdebug.ini file instead of my php.ini, because I use different domains on my server with plesk.

When doing a phpinfo, I see, that everything was installed:

This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with the ionCube PHP Loader v4.0.7, Copyright (c) 2002-2011, by ionCube Ltd., and
    with Xdebug v2.1.2, Copyright (c) 2002-2011, by Derick Rethans

But why is phpStorm not able to establish a connection?

Thank you,
Adrian.
4 comments
Comment actions Permalink

Hello Adrian,

Do you really need to use Xdebug proxy? It only required for team development(see http://derickrethans.nl/debugging-with-multiple-users.html).

This is my xdebug.ini file in my conf.d folder of /etc/php5/apache2/:

zend_extension = /usr/lib/php5/20090626/xdebug.so
xdebug.remote_enable = 1
xdebug.remote_port = 9000



What is the value of 'xdebug.remote_host' (http://xdebug.org/docs/remote#remote_host)?
See http://confluence.jetbrains.net/display/WI/Xdebug+installation+guide for details.

Thank you for feedback!

0
Comment actions Permalink

Hello Nikolay,
thank you for your help.
I do not need proxy, but I did not know how to switch it off. phpStorm always asks me to connect to a proxy....  but I think the problem was a problem of my virtual linux server which I use.
I had the same xdebug.ini file you use...

But I changed my "coding" strategy:
Right now I created 1) a productive server on that virtual server (error showing of course switched off, no xdebug installed) 2) a development server using a different domain on that virtual server (error showin on, xdebug off) and 3) a development local server on my notebook, using svn copies of my coding data and a web server running on that local notebook where I do the "fast" coding and the extensive testing with xdebug installed. Here xdebug works fine with phpStorm.
So I am happy that I found "my" perfect development workflow.

Otherwise I would like to know why xdebug did not work with my virtual linux server and phpStorm... hmm... maybe it is a problem with the linux virtual server, because PLESK is used, and as far as I know, PLESK uses some "own" config files when the apache starts... so maybe I have to investigate this.

All in all - thank you for your support and for the development of that great IDE: phpStorm really rocks, and your support is great!
Keep on developing in this manner.

Sincerely, best wishes Adrian.

0
Comment actions Permalink

Adrian,

I do not need proxy, but I did not know how to switch it off. phpStorm always asks me to connect to a proxy....

Please provide a screenshot of the error message. As an author of the Xdebug integration in PhpStorm I am pretty sure that PhpStorm doesn't require to connect to Xdebug Proxy.

Otherwise I would like to know why xdebug did not work with my virtual linux server and phpStorm... hmm... maybe it is a problem with the linux virtual server, because PLESK is used, and as far as I know, PLESK uses some "own" config files when the apache starts... so maybe I have to investigate this.

Just check your 'phpinfo()' output or call 'ini_get(...)' directly from your code to get the actual values of configuration options.

All in all - thank you for your support and for the development of that great IDE: phpStorm really rocks, and your support is great!
Keep on developing in this manner.

Thanks!:)

0
Comment actions Permalink

Hi Nikolay,
it is fine for me now. Because I configured phpStorm now for using with the server and testserver like I mentioned above, xdebug works for me on my testserver, so I really think the problem was due to the configuration of my mainserver (virtual linux server). Right now I do not have any screenshots to provide with this error, because I do not have any errors now... :-) I hope you understand. When I will be in the need of setting up xdebug on my mainserver, I will contact you again, ok?
All in all - Nikolay, thank you very much for your best support and this great piece of software. I am really sure that phpStorm is really the best php IDE that is out.
Best wishes from Munich,
Adrian.

0

Please sign in to leave a comment.