How to edit SVN settings?

I have a project that is linked to SVN. I can not find where I got to change the connection settings such as username and password for the connection. Please advise where I need to go to edit these settings.

7 comments

Open File|Settings, type or paste Subversion into search box.

0

Entering "subversion" in the text box gives me two options. The first is Version Control, and the a subcategory called Subversion. In the Subversion section, the only option I see that looks close is Edit Network Options, but that only has places to add proxy settings. In Version Control, I have a single entry listed, Directory: <Project> | VCS: Subversion. If I select that option and click Edit, Project is selected, VCS is set to Subversion, and if I click Configure VCS, I am taken to the same screen I have when I click Edit Network Options to set up the proxy settings. I am not seeing the option to change the login or URL settings anywhere.

0

URL is stored in the .svn metadata directories, if you want to change it, you need to use Relocate.
User name and password are cached, you can Clear the authentication cache in SVN Settings dialog and then IDE will show you authentication error when you try to perform any operation, click on the error to enter new user name and password.

0

Ok, thanks. I think this answers my main question, I cleared the cache and entered my username and new password. However, it still doesn't connect. I am prompted for the username, password, and a port number. My SVN uses a non-typical port (400) so I enter that, but I get an error message that connection to svn+ssl://my.server.com:22 failed. I followed the exact same procedure in PHPStorm 2.1 and it worked as expected, so I'm not sure if this is a bug in the EAP versions or if I am still doing something wrong.

0

Does it work from the terminal? What repository root is stored in the .svn metadata?

0

It works from Tortoise, the command line, Zend Studio, and version 2.1 of PHPStorm. I looked in .svn/entries and the start of the file is the following.

10

dir
2132
svn+ssh://username@my.server.com/home/svn/repo
svn+ssh://username@my.server.com/home/svn/repo








svn:special

0

It appears to be EAP specific issue. Please file a bug at http://youtrack.jetbrains.net/issues/IDEA.

0

Please sign in to leave a comment.