Debugging only works with breakpoint on first line

My question is very similar to this question: http://devnet.jetbrains.net/thread/304553

I upgraded to 2.1.4 a week or so ago.  Since then, I cannot debug my projects.  I do not use any sym links anywhere, so that should not be the problem.  The only way I am able to successfully use the debugger is if I either check off "Break at the first line" or if I actually put a break point at the first line.

When I do either one of these, the debugger will be triggered and will be stopped at the first line.  I can continue stepping over or stepping in through the completion of the request.  However, if I just continue the script by hitting "Play" then no other break points are honored.  If I don't have a break point on the first line, then the debugger is never even triggered.

I have been extremely pleased with PHPStorm thus far, and I am going to be making a recommendation for a debugger for all of my developers in the coming weeks.  If I can figure out this issue then PHPStorm is the clear choice of the 3 debuggers we have been evaluating, but this right now is a deal breaker.

Any help is appreciated.  I can supply any logs or configuration files needed.

43 comments
Comment actions Permalink

Hello Marc,

Thanks for the log file. Actually debugger accepted only one breakpoint - at testfile.php:3. It means that information about other breakpoints just wasn't send by IDE.
The only reason for that - wrong path mappings. Please disable 'Use path mappings checkbox' in server configuration (Project Settings | PHP | PHP Servers. Select server with host name 'localhost') and provide screenshot of your server configuration.
Also I suggest you use debugging bookmarklets(http://www.jetbrains.com/phpstorm/marklets/) instead of Zend Toolbar - it is better integrated with PhpStorm.

Thank you for feedback!

0
Comment actions Permalink

I've got the identical problem, however, I do not believe a PHPStorm upgrade triggered this, I have not upgraded in a while.  I'm on 2.1.2.  The only thing that recently changed in my environment is the install of Eclipse and the Android SDK so maybe that is related.

Where do we stand on this issue and what can I do to get a resolution?  Very difficult to debug now but I'm sure everyone realizes that.

Thanks.

0
Comment actions Permalink

Hello Gary,

Sorry for delay.
Please provide screenshot of your server configuration (Project Settings | PHP | Servers).

Thank you for feedback!

0
Comment actions Permalink

Marc,

Do you still have the issue?

Thank you for feedback!

0
Comment actions Permalink

no, it seems to be better now.  It may be related to another change I made.  I was still having the problem with http://devnet.jetbrains.net/thread/311067?tstart=0 regarding warnings about include.

The problem went away when I changed the default directory, so I no longer got the warning.  But around this time, I also got the problems with breakpoints.  The problem was that it was not deterministic.  I saved the project and restarted and the problem with breakpoints did not go away.  But a few days later, it did.

In the meantime, I'm continuing like this (I'm also sticking with 2.1.2, but if the problem reoccurs, you should really give me better support and do a webex or something to help solve this problem, because it's not just me.  

Marc

0
Comment actions Permalink

Marc,

no, it seems to be better now.  It may be related to another change I made.  I was still having the problem with http://devnet.jetbrains.net/thread/311067?tstart=0 regarding warnings about include.

Please vote - http://youtrack.jetbrains.net/issue/WI-7191.

In the meantime, I'm continuing like this (I'm also sticking with 2.1.2, but if the problem reoccurs, you should really give me better support and do a webex or something to help solve this problem, because it's not just me.

Sorry for delays. Actually I added one usefull feature(will be available in the next PhpStorm EAP) based on your feedback: when you step into to a script outside the project(I am pretty sure it was the reason in your case), PhpStrom will show you a warning message with the suggestion to fix path mappings. Also I would like to find the problem in your case. Please provide screenshot of your server configuration (see Project Settings | PHP | Servers).

Thank you for feedback!

0
Comment actions Permalink

I am also experiencing this problem. Debugging in PHP behaves almost normally if "break at first line is enabled" or if there is a breakpoint set at the beginning of the file. All other breakpoints, however, are ignored.

0
Comment actions Permalink

Wow... it's working fine now and I have not tried anything nor done anything to the environment, and I can no longer reproduce the issue.  Nikolay, I do not have anything in my Project Settings | PHP | Servers config, I'm only debugging local scripts.  If this problem reoccurs, I will chime back in.  Thanks for responding.

0
Comment actions Permalink

Any progress on identifying the causes, as well as solutions / workarounds, of this problem?

0
Comment actions Permalink

Hello Alexander,

Sorry for delay.
Please create a separate forum thead for your problem - it is getting hard to maintain such huge threads.
Also please attach xdebug log(see http://xdebug.org/docs/remote#remote_log) and the screenshot of your server configuration(see Project Settings|PHP|Servers) to the newly created thread.

Thank you for feedback!

0
Comment actions Permalink

Alexander,

Do you still have the issue?

Thank you for feedback!

0
Comment actions Permalink

Yes, I am still having the problem. I just began a new thread with the information you requested here: http://devnet.jetbrains.net/thread/316462 .

0
Comment actions Permalink

Alexander,

Thanks!

0

Please sign in to leave a comment.