Problems with Debug mappings

Hi,

I've a Problem regarding the Mapping of xdebug, my Project files itself are not the problem but we got some files on the server that simply hold php arrays and show us the data present for the active page, now those files i simply cant sync to my local pc, because there are about 140k of files in one folder updated nearly every hour, so i need to tell the debugger to simply skip those files. (by path or simply ignore missing mappings)

I've seen there should be a option to tell the debugger to not break at first line on missing mapping, but i cant seem to find it. it's nowhere present i even searched in the options xml files :(

Hopefully anyone can help me...


- Dominik

4 comments
Comment actions Permalink

Yes, please. For the love of all that is debugging.... This is sooooooo damn obnoxious when I have two projects open, and one project complains that it cannot find the file mapping on the other project. I do not care. I setup my file mappings. And they work perfectly. If PhpStorm comes across a mapping it does not know, it should completely ignore it.

0
Comment actions Permalink

Hello Dominik,

The issue was resolved in the first PhpStorm 3.0 EAP build - http://youtrack.jetbrains.net/issue/WI-7042.
You can find a link here - http://confluence.jetbrains.net/display/WI/Web+IDE+EAP
The kind of workaround for the issue - http://youtrack.jetbrains.net/issue/WI-7042#comment=27-238449

Thank you for feedback!

0
Comment actions Permalink

Hello Dominik,

Have you tried debugging with PhpStorm 3.0 EAP?

Thank you for feedback!

0

Please sign in to leave a comment.