Turning off auto-complete/zen coding etc. - Not everything is off?

I downloaded phpStorm today to check it out and so far I am really impressed, but I find myself constantly annoyed by the auto-complete/zen coding/smarty (or whatever you call it). I am used to ending my own tags/functions etc. and usually just end up adding extra brackets and endings and whatnot to the code, so I decided to turn it all off.. took some time but I think I have most of it off atm but I still find it auto-completing some HTML tags like <br />. How do I turn it all off?! :/

2 comments
Avatar
Eugene Kudelevsky
Comment actions Permalink

Hello,

Could you please provide more details? What exactly did you do (type anything, press enter, etc) and what undesirable behaviour did you get? Thanks!

0
Comment actions Permalink

Basically, anything that has some sort of whitespace, or slash at the end (like meta, img, br etc.) will either add the ">" at the end, or sometimes add the whitespace. I want to turn off any code-completion or help, and only have intellisense on. As it is now, there is a lot of options all over the place you need to find and turn off to do that :/

0

Please sign in to leave a comment.