automatically adding the ";" after choosing an auto completion statement

Is it possible to add the semi-colan at the end of an intelli sense completion?


if I type in "print_" i get a drop down menu letting me choose "print_r". Clicking on this will of course type in the word "print_r" for me. But it has been getting on my nerves that it doesn't fill int eh semi-colon for me.

I understand that this can be seen from another perspective and be an annoyance if the semi-colon would interfered with code on the same line. So why not have a keyboard combo to allow this.


Perhaps at the auto completion menu by pressing "command + ;" it will insert the selecte menu item with a trailing semi-colon also by clicking while holding the command key will apply the semi-colon to a clicked menu item?

3 comments
Comment actions Permalink

Only manual completion (Ctrl|Cmd+Space) can be finished by ; , and other symbols - this will both select item and type in the symbol.

Automatic completion should never interfere with normal typing and thus does not let you do this.

0
Comment actions Permalink

thank you for your quick repsond.

I tried to envoke the auto complete menu and then pressed CMD+CTRL (and vise versa) then spage, but it does nothing. Is there a settings that must be switched on for this combo to work?

0
Comment actions Permalink

Sorry for confusion. The shortcut depends on your keymap – its ether (Ctrl OR Cmd) PLUS Space.
You can look up you shortcuts in Help | Default keymap reference.
Also Help | Productivity guide and Tip of the Day are very interesting.

The Search | Find Action (type in action name) may be helpful to avoid wandering throug all main menu.

0

Please sign in to leave a comment.