HTML auto close tag is driving me crazy, how to disable?

I for the life of me cannot figure out how to disable this feature. E.g. if i type <div> it automatically adds </div> and puts the cursor in between. This would be fine, IF there were a simple way to move the cursor in ONE keystroke to the point AFTER </div>. Like hitting tab, maybe. I do like that hitting enter will put you inside that block, but sometimes I don't want this:


I just want this:


And if I do want that, I have to type <div>Howdy and then hit the right arrow key a few times to get past </div>. Isn't there a quick keystroke to do so?


cmd+right (or end) will do that most of the time


Both of those are too unreachable. I mean, from a usability perspective, it needs to be something RIGHT in reach like tab, or ctrl+enter. Ctrl+right didn't work BTW. How do I disable the auto close tag option?

EDIT: never mind, found it. It's in sort of an unintuitive spot in preferences. (smart keys??) I think it belongs in Code Completion, frankly.


Hello Jack,

Also you can try the following workflow:

1) Select a fragment of code you want to wrap with html tag:

2) Invoke 'Surround with...' action (Ctrl + Alt+T for Windows)


3) Star typing the tag name:

4) And the result would be:

Thank you for feedback!


Thanks. Is there a bug tracker or ticket system I can use to submit suggestions and bugs?



Sure, you are welcome! PhpStorm/WebStorm issue tracker -

Thank you for feedback!


Please sign in to leave a comment.