Autocomplete popup - impossible to choose with keyboard arrows or the Enter key

This is mainly the reason I can not upgrade to PhpStorm 2.

I'm on Mac OS X 10.6.7.

I search here for this problem, I not found anything similar. Perhaps I used the wrong words...

With PhpStorm 1, no problem. With PhpStorm 2, when I begin to write the first letters of a php function name or other (ex: "preg", the autocompletion popup appears. After, I can not use my keyboard to scroll down in the list, and I can not press Enter to close the popup. I can only press the Escape key, or use my mouse to choose my word. So if I really want to use this version, I have to write my functions rapidly, or disable autocompletion... I do not want to do that.

A clue? I noticed when the popup is visible, the main window loses the focus.

Any solution?

2 comments
Comment actions Permalink

No clues. May be 3rd party software interferring? SIMBL or any other hacky stuff?..
We use our products on all versions of OS X and have no problems with this. Try to getting all updates and checking on clean user profile...

0
Comment actions Permalink

Ok, I just delete my user profile (aka: the WebIDE10 folder). It resolves my problem.

Thank you!

0

Please sign in to leave a comment.