PHPStorm Debugger set-up in OS X Lion

I've been following the instructions in all the faq/help/blog posts on setting up the debugger.  I've established a connection to xdebug on my localhost, clicked on the debug (f9) option - a new browser window opens with the url:

ll1.11/?XDEBUG_SESSION_START=10442

And when I alt-tab over to PHPStorm I see:

Screen shot 2011-07-26 at 9.13.39 AM.png

As you can see, everything is pretty much disabled (step into, step over, etc.) and the debugger report it's waiting for the same connection (by ide key) that's in the browser.  I have break @ 1st line set...

When I interact/process the form page, nothing happens (on the IDE side ... the form processes...)

advthanksance....

--mike

0
9 comments

Hello Micheal,

Looks like you need to configure 'xdebug' extension. Please provide your 'phpinfo()' output (details - http://confluence.jetbrains.net/display/WI/Xdebug+installation+guide).

Thank you for feedback!

0

xdebug support enabled
Version 2.1.1

Supported protocols Revision
DBGp - Common DeBuGger Protocol $Revision: 1.145 $

Directive Local Value Master Value
xdebug.auto_trace Off Off
xdebug.collect_assignments Off Off
xdebug.collect_includes On On
xdebug.collect_params 0 0
xdebug.collect_return Off Off
xdebug.collect_vars Off Off
xdebug.default_enable On On
xdebug.dump.COOKIE no value no value
xdebug.dump.ENV no value no value
xdebug.dump.FILES no value no value
xdebug.dump.GET no value no value
xdebug.dump.POST no value no value
xdebug.dump.REQUEST no value no value
xdebug.dump.SERVER no value no value
xdebug.dump.SESSION no value no value
xdebug.dump_globals On On
xdebug.dump_once On On
xdebug.dump_undefined Off Off
xdebug.extended_info On On
xdebug.file_link_format no value no value
xdebug.idekey no value no value
xdebug.manual_url http://www.php.net http://www.php.net
xdebug.max_nesting_level 100 100
xdebug.overload_var_dump On On
xdebug.profiler_aggregate Off Off
xdebug.profiler_append Off Off
xdebug.profiler_enable Off Off
xdebug.profiler_enable_trigger Off Off
xdebug.profiler_output_dir /var/tmp/ /var/tmp/
xdebug.profiler_output_name cachegrind.out.%p cachegrind.out.%p
xdebug.remote_autostart Off Off
xdebug.remote_connect_back Off Off
xdebug.remote_cookie_expire_time 3600 3600
xdebug.remote_enable Off Off
xdebug.remote_handler dbgp dbgp
xdebug.remote_host localhost localhost
xdebug.remote_log no value no value
xdebug.remote_mode req req
xdebug.remote_port 9000 9000
xdebug.scream Off Off
xdebug.show_exception_trace Off Off
xdebug.show_local_vars Off Off
xdebug.show_mem_delta Off Off
xdebug.trace_format 0 0
xdebug.trace_options 0 0
xdebug.trace_output_dir /var/tmp/ /var/tmp/
xdebug.trace_output_name trace.%c trace.%c
xdebug.var_display_max_children 128 128
xdebug.var_display_max_data 512 512
xdebug.var_display_max_depth 3 3

0

Got it.

I was configuring the xdebug.ini file in:

/opt/local/etc/php5/conf.d/xdebug.ini

when I should have been configuring the xdebug.ini file in:

/opt/local/var/db/php5/xdebug.ini

Everything is working great now - thank you for getting me pointed in the right direction!

0

Michael,

Also I suggest you to try browser initiated debugging workflow - http://confluence.jetbrains.net/display/WI/Zero-Configuration+debugging+with+PhpStorm+2.0
It is much more handy!

Thank you for feedback!

0

Hi.  Me again.

PHPStorm 2.1 and Mac OS X/Lion

I did something bad, apparently.  I restarted my IDE and I lost all debugging capability.  This isn't the first time I've restarted the IDE, but it is the first time I've restarted it and lost debugging.

I've repeated all the steps I could find to try to get the debugger back online, but no luck.

As before, I still see the xdebug block via phpinfo()...

When I click on Tools->Xdebug->Register IDE I see an error message:

Xdebug Proxy
Cannot connect to xdebug proxy on 127.0.0.1:9001

But...my xdebug port is set to 9000 in PHPStorm preferences and in /opt/local/var/db/php5/xdeug.ini

Enabling debug in the browser (by clicking on the macro (which also never seems to work for me) or by clicking on the xdebug-helper extension icon (which is what I was using to launch an xdebug session previously) work.

I've gone back and tried with the option to start debugging at the first line of code - nothing.

Reloading via the debug this page macro - nothing.

I have the xdebug_session variable set to 'phpstorm', or to the pid value if I launch from phpstorm (clicking on debugRun --- get the waiting for incoming connection with ide key '10573' and in my browser, I see that '?XDEBUG_SESSION_START=10573' has been appended to the URL....also, xdebug_session sessionvar has been set to this pid.

still nothing.

pretty much anything at this point would be helpful - thanks!


--mike

0

xdebug.ini file:
----------------------
zend_extension=/opt/local/lib/php/extensions/no-debug-non-zts-20090626/xdebug.so
xdebug.remote_host = 127.0.0.1
xdebug.remote_enable = on
xdebug.remote_key = "phpstorm"
xdebug.remote_port = 9000
xdebug.remote_handler = dbgp
xdebug.remote_mode = req
xdebug.remote_log = /htdocs/logs/xdebug.log



In the IDE config:

XDebug port = 9000
Can accept external connections (checked)
unchecked everything else

....
0

I went and read some of the other messages of similar nature in the forum and so tried rebooting my machine.

I *hate* it when that "solves" the issue as I still have no idea what the issue was in the first place.

So, back to work....

0

Been trying for two days to get xdebug and phpstorm to work

xdebug

xdebug support enabled
Version 2.1.1

Supported protocols Revision
DBGp - Common DeBuGger Protocol $Revision: 1.145 $

Directive Local Value Master Value
xdebug.auto_trace Off Off
xdebug.collect_assignments Off Off
xdebug.collect_includes On On
xdebug.collect_params 0 0
xdebug.collect_return Off Off
xdebug.collect_vars Off Off
xdebug.default_enable On On
xdebug.dump.COOKIE no value no value
xdebug.dump.ENV no value no value
xdebug.dump.FILES no value no value
xdebug.dump.GET no value no value
xdebug.dump.POST no value no value
xdebug.dump.REQUEST no value no value
xdebug.dump.SERVER no value no value
xdebug.dump.SESSION no value no value
xdebug.dump_globals On

On

xdebug.dump_once On On
xdebug.dump_undefined Off Off
xdebug.extended_info On On
xdebug.file_link_format no value no value
xdebug.idekey phpstorm phpstorm
xdebug.manual_url http://www.php.net http://www.php.net
xdebug.max_nesting_level 100 100
xdebug.overload_var_dump On On
xdebug.profiler_aggregate Off Off
xdebug.profiler_append Off Off
xdebug.profiler_enable Off Off
xdebug.profiler_enable_trigger Off Off
xdebug.profiler_output_dir /var/tmp/ /var/tmp/
xdebug.profiler_output_name cachegrind.out.%p cachegrind.out.%p
xdebug.remote_autostart Off Off
xdebug.remote_connect_back Off Off
xdebug.remote_cookie_expire_time 3600 3600
xdebug.remote_enable On On
xdebug.remote_handler dbgp dbgp
xdebug.remote_host 127.0.0.1 127.0.0.1
xdebug.remote_log no value no value
xdebug.remote_mode req req
xdebug.remote_port 9000 9000
xdebug.scream Off Off
xdebug.show_exception_trace Off Off
xdebug.show_local_vars Off Off
xdebug.show_mem_delta Off Off
xdebug.trace_format 0 0
xdebug.trace_options 0 0
xdebug.trace_output_dir /var/tmp/ /var/tmp/
xdebug.trace_output_name trace.%c trace.%c
xdebug.var_display_max_children 128 128
xdebug.var_display_max_data 512 512
xdebug.var_display_max_depth 3 3



i've tried booklets, plugins for firefox, and starting from phpstorm. once in a while when I start from phpstorm it will work for a moment (break on start up) but will not work for any break points I put in (and yes I do go through the code during execution)

thanks for your help!

0

Hello Micheal,

When I click on Tools->Xdebug->Register IDE I see an error message:


Xdebug Proxy
Cannot connect to xdebug proxy on 127.0.0.1:9001

But...my xdebug port is set to 9000 in PHPStorm preferences and in /opt/local/var/db/php5/xdeug.ini


'Xdebug Proxy' feature is about Debugging with multiple users.

Enabling debug in the browser (by clicking on the macro (which also never seems to work for me) or by clicking on the xdebug-helper extension icon (which is what I was using to launch an xdebug session previously) work.


After enabling debug in browser you should enalbe 'Start listen debug connections' button:
listen_debug_connections.png


Does it work for you?

Thank you for feedback!

0

Please sign in to leave a comment.