WebStorm bug, High Light Current Scope

There appears to be a bug in current scope.

Recipe:

  1. Install a new color scheme such as Stella from the PhpStorm color scheme links
  2. Open an HTML file or JS file and click in a sope area


Notice that the scope highlight is not showing even though it is marked as one.  I've attached two screen shots:

  1. The first shows that the scope highlight in the gutter is now showing
  2. The second shows that scope highlight is on


When I switch back to the Default color scheme the scope highlight appears again.

Thanks,

  Mark



Attachment(s):
scope-highlight is on.png
no-scope.png
4 comments
Comment actions Permalink

Hi Mark,

Can you please show a screenshot with working hightlight and show exactly what is wrong (hightlight that area/feature on screenshot somehow). Thing is -- you possibly confused with scopes -- the first screenshot "scope-highlight is on" is to do with file-scopes (on Project View tool window click drop-down box "View As" -- here you will see your file-based scopes) while your second screenshot (the dark theme) may refer to a completely different thing.

0
Comment actions Permalink

Hi Andriy,

My mistake.  So sorry for the mixup.  My screenshots are incorrect.  Here are the new ones.

It's the:

  Files/Settings/Editor
    "Highlight on Caret Movement"
      "Highlight current scope"


feature that appears to be not working for me.

File annotated-default-scope-highlight.jpg shows the scope highlight working in default scheme.  I tried turning it off and see that it does not appear in the editor, which is the correct behavior.

Then I switch the color scheme to Stella.

The file annotated-stella-highlight-current-scope.jpg shows the "Highlight current scope" is marked on.  The file annotated-stella-no-scope.png shows the scope highlight line in the gutter is not appearing.

Any insight into what may be amiss?

Thanks Andriy, and sorry again for my mistake.

  Mark



Attachment(s):
annoted-stella-no-scope.png
annotated-stella-highlight-current-scope.jpg
annotated-default-scope-highlight.jpg
0
Comment actions Permalink

Hi Mark,

The color is controlled by this style: File | Settings | Editor | Colors & Fonts | General --> Matched Brace

You will need to change the background color property.

0
Comment actions Permalink

That worked.  Thank you!

  Mark

0

Please sign in to leave a comment.