How to disable indexing for cetrain directories?

Hello,

I have directory with compiled templates, javascripts and css files. It is really big and it is under main project folder.
Is there any way to disable this directory from indexing? Every time when I'm recompiling templates, javascripts etc. I have to wait and my pc getting stuck.

Thank you.

38 comments
Comment actions Permalink

Press ctrl+shift+a (find action), type "registry" and open it.

Find indexer.follows.symlinks property and remove the checkmark against it.

Run File > Invalidate Caches/Restart > Invalidate and Restart and check the issue after that.

0
Comment actions Permalink

Yeah, as commented elsewhere it doesn't work. Or doesn't appear to. Why the indexer can't simply honour the "excluded" tag I'm not sure but I assume there's a good reason. Some indication of where the indexer is grinding to a halt would be nice. This is seriously hindering me and many others.

0
Comment actions Permalink

I solved by moving to a different product SlickEdit it works much better and doesn't crash/freeze while indexing is running in background stuck at 1%.. I have 250GB of data in multiple folders used as assets for the project that are marked as orange (excluded) but somehow they are still indexed and cannot be canceled not stopped.. This exclude from indexng is an useless feature, same issue with last 2019 product version. Best Regards, Davide

1
Comment actions Permalink

Dlistello, it shouldn't be the case if 1) you are not using symlinks in your project 2) if you have not added these folders as PHP Include or JavaScript libraries.
Please share a screenshot of the Project tool window if neither one is your case.

0
Comment actions Permalink

I quit using it too. I just can't fathom as to why they keep ignoring the need to really ignore tagged directories or symlinks. I was symlinking to terabytes of asset data and IJ kept freezing.  How difficult can it be to tell the indexer to ignore "ignored" directories? 

0
Comment actions Permalink

@Richard Riley:

did you try to troubleshoot this with us first? I would strongly recommend getting in touch with us via Help | Contact Support to check your project config.

0
Comment actions Permalink

This problem happen still today with Pycharm version 2019.2.3 Comunity Edition and probably also Ultimate edition.

 



As you can see is trying to index folders that are excluded and contain about 250GB of logs !
This process can take up to 3 days to completly open and finish refresh background process, during this time the IDE cannot be used at all.
Unless the 2GB assigned to JVM finish and no memory is available in that case, the Pycharm process would crash.

To download the IDEA project please follow this link, I shared .idea zipped root project folder:

https://drive.google.com/file/d/13J35pLcLJL8CmRSTXwXlf2j9tZ3TSLLV

Thanks for helping to solve this annoying issue.

Cheers,
Davide

0
Comment actions Permalink

Disable/remove symlinks (specially to cifs mounts) otherwise PyCharm ignores the ignored folders. When multiple project windows are open this is much more acute.

0

Please sign in to leave a comment.