IDE freezes in Os/X

Hello,

Mostly I'm a fan of PhpStorm, but here is something I experience as a regression in 2.10.

The same day as I upgraded from 2.01 to 2.10 the IDE would start to hang for significant time periods, not only when rebuilding various indexes.

It will freeze for anything like 10 secs to a 3 minutes, with PhpStom / Idea going up to 100...200% CPU activity. The text editor is totally locked at this time, so I cannoot use the IDE then.I don't see any messages indicating what PhpStorm is busy with. After a few minutes, CPU activity goes down, and the IDE can be used again.But usually it happens again within the next few minutes.

I used 2.01 a lot, withut experiencing this (yes, indexing on project opening, but not after that).

One observation is that the "launchd" process is often quite high in task monitor / top during these freezes.

I have the feeling it happens without doing anything significant in the IDE. It can happen after hitting "Enter" in the text editor, opening a folder in the project directory browser.

Could it have to do with a specific plugin ?

Do you know if this is fixed in 2.11 ?

Please advice, so I can be comfortable with this otherwise well balanced IDE.

Regards
// Arne S.



Attachment(s):
PhpStormSuddenCpuUse.png
4 comments
Comment actions Permalink

Please upgrade to lastest version - 2.1.1

In case of problems please follow http://devnet.jetbrains.net/docs/DOC-192

0
Comment actions Permalink

Hello,

i had the same problems with one of the EAP's. As far as i can see, it happened, when i have opened a project directly from a mounted drive (VMWare via Samba).

With the new stable version, these problems are gone...

Thomas

0
Comment actions Permalink

Note: working directly from any non-local storage is officially unsupported.

0
Comment actions Permalink

I upgraded to 2.1.1 today and it was much better afterwards.

Regards
// Arne S.

0

Please sign in to leave a comment.