Honor "CamelHumps" misteriously stopped working! 2.1

Hello,

This is very frustrating, there is no reason whatsoever why this would just stop working :(. My Preferences -> IDE Settings -> Editor -> Honor "CamelHumps" blah blah.

I don't have much information to give other that Phpstorm 2.1 crashed, then I was forced to Force Quit it ( I am on OSX), and then it just stopped working.

Any ideas, besides a clean installation.


Best ,
Fotis

4 comments
Comment actions Permalink

Hi Fotis,

Try restarting PhpStorm.

If still nothing -- I recommend trying this (I know, it sound a bit stupid, but it helped me once a while ago with another setting):
1) Go to the settings and uncheck that option
2) Save settings and restart PhpStorm
3) Go back to settings and turn it ON

I'm not 100% sure about step #2 (it was quite a while ago when I has such problem), but try it.

0
Comment actions Permalink

Hello Andriy,

Actually I went as far as deleting my ~/Library/Preferences/WebIDE10 and still nothing!.

This is really messing with my productivity, I really appreciate your help.


Best,
Fotis

0
Comment actions Permalink

If you went that far and PhpStorm has recreated all settings from scratch and it still does not work .. then I have no much to say I'm afraid :(

I would suggest restart whole computer .. but you are on Mac and this universal-Windows-recipe makes no much sense for a Mac OS.

Dunno... try deleting Cache as well... (but back it up first as your Local History and Shelved Changes will be deleted as well, if you are using them).

Other than that -- no more bright ideas :(.

0
Comment actions Permalink

Well,

I have an idea :)

What is the difference between:

Preferences -> IDE Settings -> Editor -> Smart Keys -> Use "CamelHumps" words

and

Preferences -> IDE Settings -> Editors -> Advanced mouse usages -> Honor "CamelHumps" words settings .....


Well that one is for the keyboard and the other for the mouse, that is what I get for not reading carefully.


Of course the mistery still remains, why the first option went away.

Thanks once again.

Best,
Fotis

0

Please sign in to leave a comment.