PhpStorm invoking error colors in code, not sure where to set 'root'

I installed Wordprss on my server, as have with many prior versions of PS, then used Filezilla to DL a copy to my local machine. But now, in V 2.1, when I open the local project, and deply/map it all correctly - I assume, because everythig shows up and the server version still works - V2.1 is tellng me there is an error in every line I click in (pink), or an exisiting 'com not reslover error' in brown/tan.

However, on almost overy file I open locally, PHPStorm is apparently throwing sybtax errors. This seems to be new behavior. is there something I am missing?

Look at the attached code - it should be exactly fine, yet . And the local public_html is declared as the 'root' not thru Dpeloyment, as that would make a recursive public-htm folderl, but via Setttings > Directory Resource roots > - a trertiary mapping, by the way.

I have atempted to make the Project Root (clearw), public_html, etc, and nothing seems to change.


Could someone provice a concise example of the proper configuration, or more clear instructions for this procedure?

And a I am also curious that no matter where I click withn the code, it declares 'no closing tag' and more. One exapmle shows 4 divs in a row, each in a different errror color!

If anyone can help, it would be greatly aprectiated.

Thank you Douglas



Attachment(s):
ex5.jpg
ex4_resutl_of_a_find.jpg
ex3_clicked on div colophon.jpg
ex2_clicked on div colophon.jpg
ex1_clicked on div footer.jpg
1 comment
Comment actions Permalink

Hello douglas,

I work with WordPress and other platforms everyday in phpStorm. But to help you out, I need more information on your development setup.

What OS are you running for a computer? Windows (version), Mac, Linux?
Are you running a local LAMP stack of any kind? or are you just deploying everything from the IDE to the live server?

0

Please sign in to leave a comment.