macosx16 hangs on project. How to recvover?

I'm no mac expert, I am trying to move myself from windows. I find my phpstorm project hangs while loading and I have to force quit.
So I renamed the project folder and started over.
Same problem.

Are there additional cache/temp folders I can delete to slap this thing into starting up again?

7 comments
Comment actions Permalink

Hi Steward,

~/Library/Caches/WebIDE10 -- This is the folder where PhpStorm/WenStom stores its' indexes/caches. Try deleting/emptying that folder.

You can also look for other WebIDE10 subfolders within ~/Library and do the same (but try the above first and back them up, just in case) except ~/Library/Preferences/WebIDE10 as this is the folder where all settings for PhpStorm are stored.

As for the project itself -- you can delete .idea subfolder within project folder to delete this particular project settings.

0
Comment actions Permalink

Good thank you.
Deleting the project (idea) doesn't  help.
Deleting the Library/Cache also does not help.

Now I have a reproduce-able problem.
When I open this project it goes through the "Redindexing" business, and a blue progress bar works it's way from left to right.
It reaches the 100% mark but never clears and the notice does not go away.
At this point I have to force quit phpStorm.


I am looking for more "WebIDE10" folders but the finder / search reports none at all (?!)
As I'm not very experienced with mac yet, I am not sure how else to search. I'll try the find command at the terminal prompt perhaps.

When I force quit, I have the option of looking at an error report (to be sent to Apple).
Is that useful to anyone here?

I am NOT connected to the internet. Is it that simple? Does phpStorm require an active internet connection?

0
Comment actions Permalink

Well .. I'm not a Mac user either -- just had it in my possession for around 2 weeks (but have not used PhpStorm on it).

1) Which version of PhpStorm do you use specifically?
2) WebIDE10 -- I think MacOS is a case-sensitive OS, so double check the spelling when searching as on Windows such folder is spelled WebIde10
3) I would suggest to attach the log files from ~/Library/Logs/WebIDE10 to this thread so that devs can look into it. If you concerned about any privacy issues (whatever may be in those logs) then submit a new ticket on Issue Tracker and attach such logs with visibility set to "idea-developers".

0
Comment actions Permalink

Hi steward,

Have you solved this issue?

I just run into similar issue myself and apparently it was an Apache config files support plugin -- it crushes IDE under some circumstances (the issue is now fixed -- wait for next EAP build). If you using EAP build and have .htaccess files in your project, try disabling that plugin (or temporarily exlude that .htaccess file from the project).

0
Comment actions Permalink

I did find the issue. Solve it I cannot. It is particular to the software I was developing for: phpFox a social networking package.

The phpFox package creates a directory called file/cache, and dumps out all kinds of poo: js, gzip, php... prepared pages, who knows what all....

The directory must be excluded from the project. Otherwise phpStorm hangs trying to index it.

I suppose I should submit a ticket with the files. But I keep hoping I won't hhave to look at phpFox much longer...

0
Comment actions Permalink

Can you delete the content of that folder? This is cache folder, so I guess you should be able unless you are opening it directly on live server.

If you can:
1) Empty that folder
2) Start PhpStorm, open the project
3) File | Settings | Directories --> Mark that folder as Excluded

If you cannot -- you still can mark it as excluded manually (by editing project config file):
1) Close PhpStorm (or at least that project)
2) Go to project folder, .idea subfolder
3) There will be a file like %PROJECTNAME%.iml (if you call your project abcd the file will be called abcd.iml).
4) Make a back up of this file (just in case) and open that file in text editor
5) Add excluded folder entry (see below)
6) Open project in PhpStorm

This is an example of such file (the bold line in the one you need to add -- just adjust the path accordingly). If unsure -- try it on a simple test project first.

<?xml version="1.0" encoding="UTF-8"?>
<module type="WEB_MODULE" version="4">
  <component name="NewModuleRootManager">
    <content url="file://$MODULE_DIR$">
      <excludeFolder url="file://$MODULE_DIR$/.idea" />
      <excludeFolder url="file://$MODULE_DIR$/file/cache" />
    </content>
    <orderEntry type="inheritedJdk" />
    <orderEntry type="sourceFolder" forTests="false" />
    <orderEntry type="module-library">
      <library name="PHP 5.3.6">
        <CLASSES>
          <root url="file://$MODULE_DIR$/../_library/stubs" />
        </CLASSES>
        <SOURCES />
      </library>
    </orderEntry>
  </component>
</module>

0
Comment actions Permalink

Perfect thank you Andriy. You are my hero.

0

Please sign in to leave a comment.